axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From charitha kankanamge <chari...@wso2.com>
Subject Re: Error Validating Axis2 Installation
Date Thu, 18 Sep 2008 15:17:13 GMT
blakep wrote:

>Hello all! I have been tasked with getting a web service up and running and
>chose to use Apache Axis. 
>
>Here is my current setup:
>Apache Axis2 1.3 (have also tried 1.4)
>Tomcat 5.5.17
>Win XP with latest service pack
>
>I installed the Axis war and all the initial links work except for Validate.
>When I try to launch HappyAxis.jsp to verify installation of Axis2 I get a
>NumberFormatException. I was initally getting a servlet error on startup but
>took out the servlet-api-2.3.jar that was in the axis2/web-inf/lib folder.
>Guess it was just conflicting with the Tomcat containers servlet-api.jar.
>
>Here is a snippet from startup and then the exception:
>...
>Sep 16,2008 11:27:34 AM org.apache.catalina.startup.HostConfig deployWAR
>INFO: Deploying web application archive axis2.war
>[INFO] default: init
>[INFO] AxisServlet: init
>[INFO] Deploying module: addressing-1.3
>[INFO] Deploying module: script-1.3
>[INFO] Deploying module: metadataExchange-1.3
>[INFO] Deploying module: ping-1.3
>[INFO] Deploying module: soapmonitor-1.3
>[INFO] script module activated
>[INFO] Deploying Web service: version-1.3.aar
>[INFO] jsp: init
>Sep 16,2008 11:27:39 AM org.apache.catalina.core.ApplicationContext log
>INFO: default: init
>Sep 16,2008 11:27:39 AM org.apache.catalina.core.ApplicationContext log
>INFO: jsp: init
>Sep 16,2008 11:27:39 AM org.apache.catalina.core.ApplicationContext log
>INFO: default: init
>Sep 16,2008 11:27:39 AM org.apache.catalina.core.ApplicationContext log
>INFO: jsp: init
>Sep 16,2008 11:27:39 AM org.apache.coyote.http11.Http11BaseProtocol start
>INFO: Starting Coyote HTTP/1.1 on http-8080
>Sep 16,2008 11:27:39 AM org.apache.jk.common.ChannelSocket init INFO: JK:
>ajp13 listening on /0.0.0.0:8009
>Sep 16,2008 11:27:39 AM org.apache.jk.server.JKMain start INFO: Jk running
>ID=0 time=0/16 config=null
>Sep 16,2008 11:27:39 AM org.apache.catalins.storeconfig.StoreLoader load
>INFO: Find registry server-registry.xml at classpath resource
>Sep 16,2008 11:27:39 AM org.apache.catalina.startup.Catalina start
>INFO: Server startup in 6925 ms
>[INFO] jsp: init
>[INFO] jsp: init
>[INFO] jsp: init
>
>[ERROR] Servlet.service() for servet jsp threw exception
>java.lang.NumberFormatException: For input string: ""
>at
>java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
>at java.lang.Integer.parseInt(Integer.java:468)
>at java.lang.Integer.parseInt(Integer.java:497)
>at
>org.apache.axis2.transport.http.ProxyConfiguration.confgure(ProxyConfiguration.java:185)
>
>I tried to deploy a test web service in the Tomcat webapps/axis2 folder
>(Calculator.jws that is on the apache website) but get the following error:
>[INFO] Unable to parse request URL [axis2/Calculator.jws][/axis2/services]
>  
>
I think you followed the instructions given in Apache Axis web site to 
install and deploy services on Axis2 . If you are using Axis2, you 
should follow the instructions given in http://ws.apache.org/axis2/
AFAIK, there is no way to deploy jws in Axis2.

>I'm guessing this is related to the fact that the Axis2 installation wont
>validate but cant be sure.
>
>Any thoughts on this?
>
>thanks in advance for any assistance,
>-Blake 
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message