axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ryan Choi (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (AXIS2-3988) using/not using generate-all generates different adb beans
Date Mon, 01 Sep 2008 04:27:44 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-3988?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12627381#action_12627381
] 

ryankicks edited comment on AXIS2-3988 at 8/31/08 9:26 PM:
-----------------------------------------------------------

Below is a stack trace from my local with the problem previously mentioned:

org.apache.axis2.AxisFault: org.apache.axis2.databinding.ADBException: Unexpected subelement
Id
	at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
	at com.zuora.api.axis2.ServiceStub.fromOM(ServiceStub.java:41576)
	at com.zuora.api.axis2.ServiceStub.query(ServiceStub.java:941)
	at com.zuora.api.base.ApiAxis2Base.query(ApiAxis2Base.java:381)
	at com.zuora.api.test.PaymentApiTest.testQuery(PaymentApiTest.java:180)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at junit.framework.TestCase.runTest(TestCase.java:154)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestReference.run(JUnit3TestReference.java:130)
	at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:460)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196)
Caused by: java.lang.Exception: org.apache.axis2.databinding.ADBException: Unexpected subelement
Id
	at com.zuora.api.axis2.ServiceStub$Payment$Factory.parse(ServiceStub.java:9114)
	at com.zuora.api.axis2.ServiceStub$ExtensionMapper.getTypeObject(ServiceStub.java:6696)
	at com.zuora.api.axis2.ServiceStub$ZObject$Factory.parse(ServiceStub.java:23500)
	at com.zuora.api.axis2.ServiceStub$QueryResult$Factory.parse(ServiceStub.java:27162)
	at com.zuora.api.axis2.ServiceStub$QueryResponse$Factory.parse(ServiceStub.java:30814)
	at com.zuora.api.axis2.ServiceStub.fromOM(ServiceStub.java:41444)
	... 19 more
Caused by: org.apache.axis2.databinding.ADBException: Unexpected subelement Id
	at com.zuora.api.axis2.ServiceStub$Payment$Factory.parse(ServiceStub.java:8903)
	... 24 more

What should I do to help get this issue resolved? It seems like the generated code is different
for me when I use the different options. Is it not the same when you generate them and diff
them?

      was (Author: ryankicks):
    Below is a stack trace from my local nothing the problem seen:

org.apache.axis2.AxisFault: org.apache.axis2.databinding.ADBException: Unexpected subelement
Id
	at org.apache.axis2.AxisFault.makeFault(AxisFault.java:430)
	at com.zuora.api.axis2.ServiceStub.fromOM(ServiceStub.java:41576)
	at com.zuora.api.axis2.ServiceStub.query(ServiceStub.java:941)
	at com.zuora.api.base.ApiAxis2Base.query(ApiAxis2Base.java:381)
	at com.zuora.api.test.PaymentApiTest.testQuery(PaymentApiTest.java:180)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
	at java.lang.reflect.Method.invoke(Method.java:597)
	at junit.framework.TestCase.runTest(TestCase.java:154)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestReference.run(JUnit3TestReference.java:130)
	at org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:460)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196)
Caused by: java.lang.Exception: org.apache.axis2.databinding.ADBException: Unexpected subelement
Id
	at com.zuora.api.axis2.ServiceStub$Payment$Factory.parse(ServiceStub.java:9114)
	at com.zuora.api.axis2.ServiceStub$ExtensionMapper.getTypeObject(ServiceStub.java:6696)
	at com.zuora.api.axis2.ServiceStub$ZObject$Factory.parse(ServiceStub.java:23500)
	at com.zuora.api.axis2.ServiceStub$QueryResult$Factory.parse(ServiceStub.java:27162)
	at com.zuora.api.axis2.ServiceStub$QueryResponse$Factory.parse(ServiceStub.java:30814)
	at com.zuora.api.axis2.ServiceStub.fromOM(ServiceStub.java:41444)
	... 19 more
Caused by: org.apache.axis2.databinding.ADBException: Unexpected subelement Id
	at com.zuora.api.axis2.ServiceStub$Payment$Factory.parse(ServiceStub.java:8903)
	... 24 more

What should I do to help get this issue resolved? It seems like the generated code is different
for me when I use the different options. Is it not the same when you generate them and diff
them?
  
> using/not using generate-all generates different adb beans
> ----------------------------------------------------------
>
>                 Key: AXIS2-3988
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3988
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: codegen
>    Affects Versions: 1.4
>         Environment: Axis 2 1.4, JDK 1.6.0_05, Windows Vista
>            Reporter: Ryan Choi
>         Attachments: diff.zip, zuora.wsdl
>
>
> i am generating the code for the attached WSDL using the following ant definition:
> 		<java classname="org.apache.axis2.wsdl.WSDL2Java" fork="true">
> 			<classpath refid="axis2.classpath" />
> 			<arg value="-d" />
> 			<arg value="adb" />
> 			<arg value="-uri" />
> 			<arg file="${api.wsdl}" />
> 			<arg value="-ss" />
> 			<arg value="-sd" />
> 			<!--
> 			<arg value="-g" />
> 			-->
> 			<arg value="-o" />
> 			<arg file="${api.generated.server}" />
> 		</java>
> When I exclude the -g (generate-all) option, the generated bean for the Account object
handles the parent ZObject's fieldsToNull and Id fields properly in the Account object itself.
When I include the -g option, the handling of the fieldsToNull and Id fields no longer appears
in the Account object. 
> I have also included a diff of the two generated Account objects, in case that will help
with the investigation.
> Thanks!

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message