axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Detelin Yordanov (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-4009) Wrong namespace of response element when having multiple namespaces
Date Tue, 09 Sep 2008 15:11:44 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-4009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12629503#action_12629503
] 

Detelin Yordanov commented on AXIS2-4009:
-----------------------------------------

Thanks Amila, it works fine now.

> Wrong namespace of response element when having multiple namespaces
> -------------------------------------------------------------------
>
>                 Key: AXIS2-4009
>                 URL: https://issues.apache.org/jira/browse/AXIS2-4009
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: adb
>    Affects Versions: 1.4
>         Environment: Axis2 1.4 (revision 677850 from 1.4 branch)
>            Reporter: Detelin Yordanov
>         Attachments: EchoService.aar
>
>
> Hi guys,
>   I'm having a simple service that echoes a custom class (BrowseResult2), which extends
another class in another package (BrowseResult1).
> I deploy the service on Axis2 1.4 (revision 677850 from 1.4 branch), the wsdl is generated
fine, however when I invoke the service the returned response uses the namespace of the BrowseResult2
class for all elements, even for the ones that are declared within BrowseResult1 (which is
in another namespace).
> Here is the request:
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
>       <soapenv:Body>
>          <ns3:echoBrowseResult xmlns:ns3="http://test.tempuri.org">
>             <ns3:browseResult xmlns:ns2="http://ns2.test.tempuri.org/xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:type="ns2:BrowseResult2">
>                <s1:field1 xmlns:s1="http://ns1.test.tempuri.org/xsd">field1</s1:field1>
>                <ns2:field2>field2</ns2:field2>
>             </ns3:browseResult>
>          </ns3:echoBrowseResult>
>       </soapenv:Body>
>    </soapenv:Envelope
> And the faulty response:
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
>    <soapenv:Body>
>       <ns:echoBrowseResultResponse xmlns:ns="http://test.tempuri.org">
>          <ns:return type="org.tempuri.test.ns2.BrowseResult2" xmlns:ax22="http://ns1.test.tempuri.org/xsd"
xmlns:ax21="http://ns2.test.tempuri.org/xsd">
>             <ax21:field1>field1</ax21:field1>
>             <ax21:field2>field2</ax21:field2>
>          </ns:return>
>       </ns:echoBrowseResultResponse>
>    </soapenv:Body>
> </soapenv:Envelope>
> As you can see field1 uses the namespace of field2 which is wrong, it should have been
using http://ns1.test.tempuri.org/xsd instead.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message