axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nandana Mihindukulasooriya" <nandana....@gmail.com>
Subject Re: Axis2 Build error
Date Mon, 11 Aug 2008 12:49:39 GMT
Hi Vidura,
         You can get this working by changing few pom.xml files.

modules/parent/pom.xml :

First you need to change the dependency

            <dependency>
                <groupId>org.apache.activemq</groupId>
                <artifactId>apache-activemq</artifactId>
                <version>${activemq.version}</version>
                .....
            <dependency>
to
            <dependency>
                <groupId>org.apache.activemq</groupId>
                <artifactId>activemq-core</artifactId>
                <version>${activemq.version}</version>
                .....
            <dependen

and then the version

          <activemq.version>5.0.0</activemq.version>
to
         <activemq.version>5.1.0</activemq.version>

modules/integration/pom.xml :

         <dependency>
             <groupId>org.apache.activemq</groupId>
             <artifactId>apache-activemq</artifactId>
         </dependency>
to
         <dependency>
             <groupId>org.apache.activemq</groupId>
             <artifactId>activemq-core</artifactId>
         </dependency>

regards,
nandana

On Mon, Aug 11, 2008 at 5:58 PM, Vidura Gamini Abhaya <viduras@gmail.com>wrote:

> Great, so which means I'm not the only one getting this error. Is there
> anything I could do with Axis2 ver 1.4 (maybe with build files) to get it to
> build properly?
>
> Thanks,
> Vidura
>
>
>
> On Fri, Aug 8, 2008 at 1:35 PM, Amila Suriarachchi <
> amilasuriarachchi@gmail.com> wrote:
>
>>
>>
>> On Fri, Aug 8, 2008 at 8:53 AM, Nandana Mihindukulasooriya <
>> nandana.cse@gmail.com> wrote:
>>
>>> Hi Devs,
>>>      I also faced the same error and seems the root cause of the problem
>>> is activemq-console:jar:5.0.0 release have a dependency to SNAPSHOT version
>>> [1] of xbean-spring.jar which seems to be not available.
>>>
>>
>>>     ActiveMQ is only used in integration tests and we have ActiveMQ 5.1.0
>>> on maven repos which doesn't have any dependency to SNAPSHOT versions. I
>>> tested changing it to 5.1.0 and everything works fine. Shall we change this
>>> dependency to 5.1.0 in Axis2 1.4.1 ?
>>>
>>
>> +1  if the integration tests passed with this release.  Since Axis2 is not
>> shifting activemq jars anyone can use 5.0.0 jars if they need.
>>
>> thanks,
>> Amila.
>>
>>>
>>>
>>> thanks,
>>> nandana
>>>
>>> [1] -
>>> http://repo1.maven.org/maven2/org/apache/activemq/activemq-parent/5.0.0/activemq-parent-5.0.0.pom
>>>
>>> On Thu, Aug 7, 2008 at 8:28 AM, Vidura Gamini Abhaya <viduras@gmail.com>wrote:
>>>
>>>> Hi,
>>>>
>>>> I'm trying to build Axis2 1.4 from its source. I get this build error
>>>> inside modules/integration,
>>>>
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [ERROR] BUILD ERROR
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] Failed to resolve artifact.
>>>>
>>>> Missing:
>>>> ----------
>>>> 1) org.apache.xbean:xbean-spring:jar:3.2-SNAPSHOT
>>>>
>>>>   Try downloading the file manually from the project website.
>>>>
>>>>   Then, install it using the command:
>>>>       mvn install:install-file -DgroupId=org.apache.xbean
>>>> -DartifactId=xbean-spring -Dversion=3.2-SNAPSHOT -Dpackaging=jar
>>>> -Dfile=/path/to/file
>>>>
>>>>   Alternatively, if you host your own repository you can deploy the file
>>>> there:
>>>>       mvn deploy:deploy-file -DgroupId=org.apache.xbean
>>>> -DartifactId=xbean-spring -Dversion=3.2-SNAPSHOT -Dpackaging=jar
>>>> -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>>>>
>>>>   Path to dependency:
>>>>       1) org.apache.axis2:axis2-integration:jar:1.4
>>>>       2) org.apache.activemq:apache-activemq:jar:5.0.0
>>>>       3) org.apache.activemq:activemq-console:jar:5.0.0
>>>>       4) org.apache.xbean:xbean-spring:jar:3.2-SNAPSHOT
>>>>
>>>> ----------
>>>> 1 required artifact is missing.
>>>>
>>>> for artifact:
>>>>   org.apache.axis2:axis2-integration:jar:1.4
>>>>
>>>> from the specified remote repositories:
>>>>   apache.snapshots (
>>>> http://people.apache.org/repo/m2-snapshot-repository),
>>>>   java.net (https://maven-repository.dev.java.net/nonav/repository/),
>>>>   eclipse-repo (http://repo1.maven.org/eclipse),
>>>>   tomcat-repository (http://tomcat.apache.org/dev/dist/m2-repository),
>>>>   central (http://repo1.maven.org/maven2),
>>>>   apache-ws-snapshots2 (http://ws.zones.apache.org/repository2)
>>>>
>>>>
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] For more information, run Maven with the -e switch
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>> [INFO] Total time: 11 seconds
>>>> [INFO] Finished at: Thu Aug 07 12:57:34 EST 2008
>>>> [INFO] Final Memory: 19M/80M
>>>> [INFO]
>>>> ------------------------------------------------------------------------
>>>>
>>>>
>>>> The required .jar doesn't seem to be in any of the repositories. I've
>>>> tried building this with Java 1.6 as well as 1.5. Is it the case or am I
>>>> doing something wrong here?
>>>>
>>>> Thanks,
>>>>
>>>> Vidura
>>>>
>>>
>>
>>
>> --
>> Amila Suriarachchi,
>> WSO2 Inc.
>>
>
>


-- 
Nandana Mihindukulasooriya
WSO2 inc.

http://nandana83.blogspot.com/
http://www.wso2.org

Mime
View raw message