axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Raihan Ahmed <ruabng2...@yahoo.com>
Subject Re: Questions regarding Axis1.4
Date Mon, 30 Jun 2008 13:20:47 GMT
I apologize!  In my last email with the attachment, I forgot to name the node that contains
the base64 data.  Even though I know you will figure it out just by looking at it, I am giving
you the name of the node anyway - 
"BinaryObject.Base64".

Thanks!
Raihan


--- On Mon, 6/30/08, WJ Krpelan <krpelan_wj@yahoo.com> wrote:

> From: WJ Krpelan <krpelan_wj@yahoo.com>
> Subject: Re: Questions regarding Axis1.4
> To: axis-dev@ws.apache.org
> Date: Monday, June 30, 2008, 5:17 AM
> Ahmed,
> its difficult to follow because I cant tell when are you
> speaking of the overall xml-document and when of an
> included xml-document. btw the xml-schema-datatype is named
> "base64Binary" and not base64. so whereever you
> use base64 data you should discover a
> "base64Binary" datatype within your
> xml-schema-document for your xml-instance-document.
> I assume here that your xml-documents are all
> xml-schema-based?
> Still I think an (anonymized) example document would say
> more than a thousand words,
> Wolfgang
> 
> 
> --- On Mon, 6/30/08, Raihan Ahmed
> <ruabng2000@yahoo.com> wrote:
> 
> > From: Raihan Ahmed <ruabng2000@yahoo.com>
> > Subject: Re: Questions regarding Axis1.4
> > To: axis-dev@ws.apache.org
> > Date: Monday, June 30, 2008, 1:36 AM
> > Hi Wolfgang,
> > Thanks a bunch for your email.  I know it is very
> unusual
> > having xml document inside xml document.  It was one
> of the
> > requirement of the client that the output has to be in
> xml
> > document.  It has data from multiple different sources
> and
> > uses Justice xml for law enforcement agencies as its
> > standard.  So far we have not run into any issues (as
> long
> > as we didn't use base64 data) with this even
> though it
> > seems weird considering that SOAP response itself is
> an xml
> > document.  Can you think of any other way we could do
> this?
> > As far as the hard-coded base64 string goes, this is
> what
> > is happening - 
> > after a client request, I query database with input
> data,
> > and parse the query result and put them in the xml
> > document.  During this process, I have to check if the
> > record has an image associated with it.  If it does,
> then I
> > get the image file, convert it into base64 and stick
> that
> > base64 string into the image tag.  And it fails.  
> > I also print this xml document out for debugging
> purposes. 
> > From this output, if I copy and paste the base64
> string into
> > the image tag (that is I am sending a hard-coded
> output),
> > then it works.  That is, my output sent to client
> always
> > has the same image data.
> > I am not sure if I was able to explain this at all. 
> Please
> > let me know if you need any more info to help me out
> with
> > this problem.
> > Thanks again!
> > Raihan
> > 
> > 
> > --- On Sun, 6/29/08, WJ Krpelan
> > <krpelan_wj@yahoo.com> wrote:
> > 
> > > From: WJ Krpelan <krpelan_wj@yahoo.com>
> > > Subject: Re: Questions regarding Axis1.4
> > > To: axis-dev@ws.apache.org
> > > Date: Sunday, June 29, 2008, 5:32 PM
> > > Hi
> > > what you are doing (putting xml documents within
> xml
> > > documents as strings)
> > > is not considered usual practice. I'm not
> > surprised
> > > that you are running into problems with AXIS 1
> using
> > this
> > > approach. 
> > > I dont understand exactly what you mean by
> putting it
> > > hardcoded vs generated into the response. could
> you
> > provide
> > > an example?
> > > Cheers,
> > > Wolfgang
> > > 
> > > 
> > > --- On Sun, 6/29/08, Raihan Ahmed
> > > <ruabng2000@yahoo.com> wrote:
> > > 
> > > > From: Raihan Ahmed
> <ruabng2000@yahoo.com>
> > > > Subject: Questions regarding Axis1.4
> > > > To: axis-dev@ws.apache.org
> > > > Date: Sunday, June 29, 2008, 6:00 AM
> > > > Hello,
> > > > I am sorry to email in this manner.  But I
> have
> > run
> > > into an
> > > > issue that I just can't figure out.  I
> have
> > > searched the
> > > > Internet without any luck.
> > > > I have a web service running under Axis1.4. 
> One
> > of
> > > the
> > > > methods returns an array of string to the
> client.
> > 
> > > Each
> > > > string in the array is actually an XML
> document
> > with
> > > data
> > > > from database tables.  And each of these XML
> > documents
> > > has
> > > > a node that has image data in Base64 string.
> 
> > > > Now the problem is this -
> > > > Without the Base64, it works fine.  But soon
> I
> > add the
> > > > base64 data in the node, I get the
> SoapException
> > on
> > > the
> > > > server side.  If I copy the base64 string
> and
> > > hard-code it
> > > > in the response, it works.  But when the
> base64
> > is
> > > > generated, it does not work.
> > > > I can't figure out the reason - base64
> is
> > simple
> > > ascii
> > > > characters.  Why can't I put a string
> like
> > that in
> > > the
> > > > response?
> > > > I am desperate.  Please help!  If I am in
> the
> > wrong
> > > place,
> > > > please point to the right people so that I
> can
> > get an
> > > > answer.
> > > > Best Regards!
> > > > Raihan U. Ahmed
> > > > 
> > > > 
> > > >       
> > > > 
> > > >
> > >
> >
> ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail:
> > > axis-dev-unsubscribe@ws.apache.org
> > > > For additional commands, e-mail:
> > > > axis-dev-help@ws.apache.org
> > > 
> > > 
> > >       
> > > 
> > >
> >
> ---------------------------------------------------------------------
> > > To unsubscribe, e-mail:
> > axis-dev-unsubscribe@ws.apache.org
> > > For additional commands, e-mail:
> > > axis-dev-help@ws.apache.org
> > 
> > 
> >       
> > 
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> axis-dev-unsubscribe@ws.apache.org
> > For additional commands, e-mail:
> > axis-dev-help@ws.apache.org
> 
> 
>       
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail:
> axis-dev-help@ws.apache.org


      

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message