axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marc Lefebvre (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-3801) Incorrect HTTP response message on axis fault for in-only messages
Date Thu, 15 May 2008 19:10:55 GMT
Incorrect HTTP response message on axis fault for in-only messages
------------------------------------------------------------------

                 Key: AXIS2-3801
                 URL: https://issues.apache.org/jira/browse/AXIS2-3801
             Project: Axis 2.0 (Axis2)
          Issue Type: Bug
         Environment: Windows XP 
Apache 2.2.6
Apache Tomcat Version 6.0.14
Apache Axis2 1.3 build  (10-08-2007)
SoapUI 2.0.2
            Reporter: Marc Lefebvre


I have SoapUI to test the Webservice, and Im trying to get some errors or faults to come back
and I am getting nothing accept an HTTP message that says:

HTTP/1.1 202 Accepted

I get this no matter what I send on INPUT only messages. 

 When i check the TOMCAT LOG, I see all the faults showing up there, but nothing is being
sent back to me.  What am I doing wrong?  Is Axis, or Tomcat not setup properly?

>>>>> 
THIS ONLY applies to Soap Messages that are INPUT only on the WSDL.  Messages that are INPUT/OUTPUT,
I get the errors fine. 
>>>>> 

We should be getting:

HTTP/1.1 500 Internal Server Error 

Which is not happening.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message