axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Srinivasan Sairam (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-3761) Client Values not transmitting properly
Date Tue, 22 Apr 2008 21:25:21 GMT
Client Values not transmitting properly
---------------------------------------

                 Key: AXIS2-3761
                 URL: https://issues.apache.org/jira/browse/AXIS2-3761
             Project: Axis 2.0 (Axis2)
          Issue Type: Bug
          Components: rpc
    Affects Versions: 1.3
         Environment: Client is invoked from (witn in Eclipse) Windows XP and Server is Linux
(RHEL 3)
            Reporter: Srinivasan Sairam


My web services is using Axis 2. 

Some of the operations in the web services, take a complex object (obj1) as an input argument.
 This input object in turn contains another object (obj2).  

Signature looks something like:

      String operation1(Object1 obj1)

Definition of Object1 : 

      String name;

      Object obj2;

Definition of Object2:

      String id = "";

The client code is generated using xml binding.  The client code has something like 

      Obj1.obj2.setId("ID");

Then the service is invoked, the operation1 receives empty string (which is the default value)
for the id element.  

In the Soap Monitor, it shows that the server (entry point) is getting the value of "ID" for
the objcet2's id element; but when it comes to the operation1 method, it is empty string.

Has anyone seen such a behavior? Is there any workarounds? 


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message