axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mangesh (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-3727) CLONE -Classpath/Classloader issue with packaging
Date Thu, 10 Apr 2008 17:26:05 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-3727?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mangesh updated AXIS2-3727:
---------------------------

    Description: 
I have classpath issue when using axis2 top-down approch (xmlbean binding) with ibatis. Apprceiate
if you can help int this.  
My aar structure is (Attached aar file)
 
com.xx..
lib/ibatis jars
lib/XBeans-packaged.jar (generated using wsdltojava)
ibatis config.prop files
 
 
But when I put aar in services directory and deploy, somehow ibatis config file is not getting
recognized.


  was:
I have one single java project in eclipse environment. It is called PhoenixWebServices. 

1. There is a file folder called "lib" that contains all the required jar files.
2. There is a folder called "xml" which contains all the iBATIS related xml files.
3. There is a folder called "META-INF" which contains all the wsdl files and the services.xml

There are separate packages for delegate, dao, dto etc.

I prepare the wsdl files by my own and then use WSDL2Java with eclipse to generate all the
code. Till now all is fine (apparently).

1. Now I export my only java project from eclipse as a .jar file. 
2. Then I rename it to .aar file. 
3. Deploy it in Axis2

All is still fine. I have test servlet which calls the service.

1. Inside the client Skeleton code in server side, I call the delegate to do all the task
and return a dto.
2. The delegate and dao needs the iBATIS xml files which I have packaged inside the .aar,
as described above.

Problem is delegate does not find the xml/*.xml files. 

Please find the .aar attached. It contains all the files.


> CLONE -Classpath/Classloader issue with packaging
> -------------------------------------------------
>
>                 Key: AXIS2-3727
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3727
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: deployment
>    Affects Versions: 1.0
>         Environment: Tomcat 5.0, Axis2 1.0, Eclipse, iBATIS
>            Reporter: Mangesh
>            Priority: Blocker
>
> I have classpath issue when using axis2 top-down approch (xmlbean binding) with ibatis.
Apprceiate if you can help int this.  
> My aar structure is (Attached aar file)
>  
> com.xx..
> lib/ibatis jars
> lib/XBeans-packaged.jar (generated using wsdltojava)
> ibatis config.prop files
>  
>  
> But when I put aar in services directory and deploy, somehow ibatis config file is not
getting recognized.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message