axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-3289) SwaTest.wsdl not found when building binary from source distribution
Date Wed, 12 Mar 2008 21:58:46 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-3289?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Davanum Srinivas updated AXIS2-3289:
------------------------------------

    Assignee: Davanum Srinivas  (was: Thilina Gunarathne)

> SwaTest.wsdl not found when building binary from source distribution
> --------------------------------------------------------------------
>
>                 Key: AXIS2-3289
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3289
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: samples, build,site
>    Affects Versions: 1.3
>         Environment: WinXP. maven 2.0.4.
>            Reporter: Kent Tong
>            Assignee: Davanum Srinivas
>             Fix For: 1.4
>
>
> I am running "mvn install" in the axis2 source directory. When running the tests, one
test will fail with
> the following error:
> [surefire] Running org.apache.axis2.description.WSDL11ToAxisServiceBuilderAttachmentTest
> testResouceFile: test-resources\wsdl\SwaTest.wsdl
> Error in WSDL : SwaTest.wsdl
> Exception: java.io.FileNotFoundException: test-resources\wsdl\SwaTest.wsdl (????
> ???????)
> java.io.FileNotFoundException: test-resources\wsdl\SwaTest.wsdl (???????????)
>         at java.io.FileInputStream.open(Native Method)
>         at java.io.FileInputStream.<init>(FileInputStream.java:106)
>         at org.apache.axis2.description.WSDL11ToAxisServiceBuilderAttachmentTest.testAttachment(WSDL11ToAxisServiceBuilderAttachmentTest.java:35)
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
> If I change into axis2\modules\kernel and run "mvn install", then it will work. 
> This is probably due to http://jira.codehaus.org/browse/SUREFIRE-191 and the line in

> WSDL11ToAxisServiceBuilderAttachmentTest.java:
>     File testResourceFile = new File("test-resources/wsdl/SwaTest.wsdl"); //relative
to the project root, not module!

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message