axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AXIS2-3420) Maven build fails due to woden dependency problem
Date Mon, 03 Mar 2008 18:52:50 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-3420?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Davanum Srinivas resolved AXIS2-3420.
-------------------------------------

    Resolution: Fixed

> Maven build fails due to woden dependency problem
> -------------------------------------------------
>
>                 Key: AXIS2-3420
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3420
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: samples, build,site
>    Affects Versions: 1.3
>            Reporter: Daniel Harvey
>
> This bug is reported and theoretically fixed in AXIS2-1791. This appears not to be the
case for Axis2 version 1.3.
> In the /axis2-1.3/samples/version/ folder, "mvn package" produces the following error:
> {code}
> [INFO] ------------------------------------------------------------------------
> [ERROR] BUILD ERROR
> [INFO] ------------------------------------------------------------------------
> [INFO] Failed to resolve artifact.
> Missing:
> ----------
> 1) org.apache.woden:woden:jar:1.0-incubating-M7b
>   Try downloading the file manually from the project website.
>   Then, install it using the command: 
>       mvn install:install-file -DgroupId=org.apache.woden -DartifactId=woden -Dversion=1.0-incubating-M7b
-Dpackaging=jar -Dfile=/path/to/file
>   Alternatively, if you host your own repository you can deploy the file there: 
>       mvn deploy:deploy-file -DgroupId=org.apache.woden -DartifactId=woden -Dversion=1.0-incubating-M7b
-Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>   Path to dependency: 
>         1) org.apache.axis2:version:aar:1.3
>         2) org.apache.axis2:axis2-kernel:jar:1.3
>         3) org.apache.woden:woden:jar:1.0-incubating-M7b
> 2) wsdl4j:wsdl4j:jar:1.6.2
>   Try downloading the file manually from the project website.
>   Then, install it using the command: 
>       mvn install:install-file -DgroupId=wsdl4j -DartifactId=wsdl4j -Dversion=1.6.2 -Dpackaging=jar
-Dfile=/path/to/file
>   Alternatively, if you host your own repository you can deploy the file there: 
>       mvn deploy:deploy-file -DgroupId=wsdl4j -DartifactId=wsdl4j -Dversion=1.6.2 -Dpackaging=jar
-Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
>   Path to dependency: 
>         1) org.apache.axis2:version:aar:1.3
>         2) org.apache.axis2:axis2-kernel:jar:1.3
>         3) wsdl4j:wsdl4j:jar:1.6.2
> ----------
> 2 required artifacts are missing.
> for artifact: 
>   org.apache.axis2:version:aar:1.3
> {code}
> The fix detailed in AXIS2-1791 was to replace the woden artifact dependency with the
incubator version. This dependency is still incorrect in version 1.3 - see http://repo1.maven.org/maven2/org/apache/axis2/axis2-kernel/1.3/axis2-kernel-1.3.pom
. Accordingly, the build fails as show above.
> Can this please be fixed?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message