axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-3451) Example maven2 configuration is broken.
Date Sun, 09 Mar 2008 03:37:46 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-3451?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Davanum Srinivas updated AXIS2-3451:
------------------------------------

    Fix Version/s: 1.4

> Example maven2 configuration is broken.
> ---------------------------------------
>
>                 Key: AXIS2-3451
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3451
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: documentation
>            Reporter: Kevin Menard
>             Fix For: 1.4
>
>
> This bug affects the following URLs:
> http://ws.apache.org/axis2/tools/1_2/maven-plugins/maven-wsdl2code-plugin.html
> http://ws.apache.org/axis2/tools/1_3/maven-plugins/maven-wsdl2code-plugin.html
> The example maven2 configuration shows the following:
>     <build>
>     	<plugins>
>     		<plugin>
>     			<groupId>org.apache.axis2.maven2</groupId>
>     			<artifactId>axis2-wsdl2code-maven-plugin</artifactId>
>    			<executions>
>     				<execution>
>     					<goals>
>     						<goal>wsdl2code</goal>
>     					</goals>
>     				</execution>
> 		    	</executions>
> 		    	<configuration>
>     				<packageName>com.foo.myservice</packageName>
>     		 	</configuration>
>     		</plugin>
>     	</plugins>
>     </build>
> This does not validate.  The configuration section must appear in the execution section.
> Additionally, that's an outdated, broken version of the plugin.  It should be:
> <groupId>org.apache.axis2</groupId>
> <artifactId>axis2-wsdl2code-maven-plugin</artifactId>
> <version>1.3</version>
> Finally, there should be a note about adding axis2 as a dependency of the project, using
something like the following:
> <dependency>
>       <groupId>org.apache.axis2</groupId>
>       <artifactId>axis2</artifactId>
>       <version>1.3</version>
> </dependency>
> This should be tailored to be version 1.2 for the 1.2 page.  In no event should 1.1 be
used for either 1.2 or 1.3 configuration instructions.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message