axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Juan Macias <mcj...@yahoo.com>
Subject Re: Axis2 1.3 WSDL2Java(WSDL11ToAxisServiceBuilder) issue with imported wsdl
Date Mon, 17 Dec 2007 17:07:10 GMT
Just got the nightly build as Amila suggested and it worked! 

Thanks Amila. 

Best Regards.

Juan Macias

Amila Suriarachchi <amilasuriarachchi@gmail.com> escribió: Can you please have look
at with a nighly build? I have fixed this issue?

thanks,
Amila.


On Dec 15, 2007 6:24 AM, Juan Macias <mcjmty@yahoo.com > wrote:
 Hi all,

I was upgrading my axis clients from Axis2 1.2 to Axis2 1.3 , and wsdl2Java now throws an
exception when I run it .

Exception in thread "Main Thread" org.apache.axis2.wsdl.codegen.CodeGenerationException: Error
parsing WSDL
     [java]     at org.apache.axis2.wsdl.codegen.CodeGenerationEngine .<init>(CodeGenerationEngine.java:147)
     [java]     at org.apache.axis2.wsdl.WSDL2Code.main(WSDL2Code.java:35)
     [java]     at org.apache.axis2.wsdl.WSDL2Java.main(WSDL2Java.java:24)
     [java] Caused by:  org.apache.axis2.AxisFault: There is no port type associated with
the binding
     [java]     at org.apache.axis2.description.WSDL11ToAxisServiceBuilder.populateService(WSDL11ToAxisServiceBuilder.java:250)
     [java]     at   org.apache.axis2.description.WSDL11ToAllAxisServicesBuilder.populateAllServices(WSDL11ToAllAxisServicesBuilder.java:109)
     [java]     at org.apache.axis2.wsdl.codegen.CodeGenerationEngine.<init>(CodeGenerationEngine.java
:141)
     [java]     ... 2 more

The WSDL that I'm using has a service definition on one file, then import another WSDL where
the binding definitions reside and inside of it one more WSDL import where the port and schema
are defined (Please see attachment for the WSDL document example). 

I have downloaded the source code from the tag for 1.3 and changed the code to get it to work,
the problem was on recursive calls to retrieve the Binding and PortType objects when the definitions
exists on a  imported WSDL, like in my case. Explicitly I change the following methods  org.apache.axis2.description.WSDL11ToAxisServiceBuilder#getPortType
and  org.apache.axis2.description.WSDL11ToAxisServiceBuilder#getBinding.

I look for the bug in the issue tracker for the project and I did not found a reference to
this issue, I'm neophyte on the open source community process, and so my questions are should
I raise a ticket on Jira? What should it be my next step? Should I avoid move to Axis2  1.3


Any advice would be helpful, thanks in advance.

Juan Macias.
            
---------------------------------

¡Capacidad ilimitada de almacenamiento en tu correo!
No te preocupes más por el espacio de tu cuenta con Correo Yahoo!:
 http://correo.espanol.yahoo.com/

---------------------------------------------------------------------
To unsubscribe, e-mail:  axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org




-- 
Amila Suriarachchi, 
WSO2 Inc. 

       
---------------------------------

¡Capacidad ilimitada de almacenamiento en tu correo!
No te preocupes más por el espacio de tu cuenta con Correo Yahoo!:
http://correo.espanol.yahoo.com/
Mime
View raw message