axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Iyengar, Kumar" <>
Subject RE: axis 1.4 and Basic Profile
Date Fri, 16 Nov 2007 07:27:06 GMT
Hi Lawrence,

I do mean WS-I Basic Profile. If I understand correctly Basic Profile
1.1 has WSDL and SOAP compliance. I understand and agree with you on the
WSDL compliance part. However, for SOAP we entirely depend on Axis and
so the compliance for SOAP part of Basic Profile 1.1 has to come from
Axis 1.x. I wanted to find out if Axis 1.4 is WS-I Basic Profile 1.1

We are currently using Axis 1.2 and that is not BP 1.1 compliant (but it
is BP 1.0 compliant).

Axis2 is considered BP 1.1 compliant but I am having problems
integrating with that.



-----Original Message-----
From: Lawrence Mandel [] 
Sent: Thursday, November 15, 2007 7:53 PM
Subject: Re: axis 1.4 and Basic Profile

Hi Kumar,

By basic profile I'm assuming you mean the WS-I basic profile. I don't 
think you can label a runtime as WS-I compliant as there are many things

that you can do with Web services that are not recommended by the WS-I -

that's why there is a WS-I - such as rpc encoded services and importing 
schemas in a WSDL document with the wsdl:import element. The real
when it comes to WS-I compliance is "is service X WS-I compliant"? If
service description and implementation follows the WS-I recommendations 
than it is compliant. Note that even if service X is compliant, service
which is deployed to the same runtime (Axis or otherwise), can be 


"Iyengar, Kumar" <> 
11/15/2007 08:45 PM
Please respond to


axis 1.4 and Basic Profile

Hi all,
Does anyone know if Axis1.4 is Basic Profile 1.1 compliant?

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message