axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Pollmeier (JIRA)" <j...@apache.org>
Subject [jira] Closed: (AXIS2-3311) WstxIOException caching problem?
Date Wed, 07 Nov 2007 16:23:50 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-3311?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Pollmeier closed AXIS2-3311.
------------------------------------


see comment before

> WstxIOException caching problem?
> --------------------------------
>
>                 Key: AXIS2-3311
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3311
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: kernel, transports
>    Affects Versions: 1.2
>         Environment: JBoss 4.0.3 SP1 
>            Reporter: Michael Pollmeier
>            Priority: Minor
>         Attachments: attachment.zip
>
>
> Hi there,
> I developed a simple forwarding service with axis2: the wsdl is in the attachment. It
receives XML, converts it to AXIOM and uses a client to send the XML to another service. As
simple as it can be, no business logic or so, just forwarding on service level. The service
has four methods.
> I encountered a curious bug: when I send the request.xml (Attachment) to the service
(method: getKontingent) once, everything works fine. But if I send exactly the same request
again, the service responds with soapFault: com.ctc.wstx.exc.WstxIOException: Attempted read
on closed stream.
> If I switch some characters in the request, everything works fine again for the first
try. If I resend the XML, the service returns the Exception again and again.
> For me it seems like a caching problem. The interesting thing is that it only happens
with one of my four methods...
> The attached attachment.zip contains:
>     * request xml
>     * the axis2 services.xml
>     * the wsdl
>     * service skeleton
>     * client stub
> I already posted this issue at Codehaus' Jira, as the Woodstox component throws the error,
but they say it is probably an issue how axis2 uses the Woodstox API: http://jira.codehaus.org/browse/WSTX-133
> I hope that helps..cheers
> Michael Pollmeier

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message