axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amila Chinthaka Suriarachchi (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-3259) ADBException: Unexpected subelement contentType
Date Wed, 10 Oct 2007 05:33:52 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-3259?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Amila Chinthaka Suriarachchi updated AXIS2-3259:
------------------------------------------------

    Attachment: knowledgebase.tar

can you please test with the generated client and send the whole stack trace. 
Can you send the exact line this exception thrown in the code I have sent to you.
I can not reproduce your problem here.

> ADBException: Unexpected subelement contentType
> -----------------------------------------------
>
>                 Key: AXIS2-3259
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3259
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: adb
>    Affects Versions: 1.3
>         Environment: WSDL2java generated client
>            Reporter: Etienne
>         Attachments: knowledgebase.tar, KnowledgeBaseService.wsdl, request.xml, response.xml
>
>
> With axis2 I have an issue with a complex type containing a
> base64Binary element:
> <xsd:complexType name="BinaryFile">
> <xsd:sequence>
> <xsd:element minOccurs="0" name="content" nillable="true"
> type="xsd:base64Binary"/>
> <xsd:element minOccurs="0" name="contentType" nillable="true"
> type="xsd:string"/>
> <xsd:element minOccurs="0" name="id" type="xsd:int"/>
> <xsd:element minOccurs="0" name="name" nillable="true" type="xsd:string"/>
> </xsd:sequence>
> </xsd:complexType>
> When the client fails with the following exception;
> org.apache.axis2.AxisFault: org.apache.axis2.databinding.ADBException:
> Unexpected subelement contentType
>        at org.apache.axis2.AxisFault.makeFault(AxisFault.java:417)
>        at com.foo.MyServiceStub.fromOM(KnowledgeBaseServiceStub.java:5805)
> When switching the server to use MTOM (only possible for testing), the issue disappear.
> Here is the discussion on axis-user: http://marc.info/?t=119142622400004&r=1&w=4
> Please see attached wsdl, request and response.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message