axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Lischke (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-3158) Generating Java 1.5 Code when using XMLBeans
Date Thu, 20 Sep 2007 05:53:12 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-3158?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Stefan Lischke updated AXIS2-3158:
----------------------------------

    Attachment: AXIS2-3158.patch

Here is the svn patch, sorry had problems with subclipse and eclipse 3.4. Please check the
patch and commit to the branch it is a really nice feature to generate java 1.5 compliant
xmlbeans code 

> Generating Java 1.5 Code when using XMLBeans
> --------------------------------------------
>
>                 Key: AXIS2-3158
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3158
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Wish
>          Components: databinding
>    Affects Versions: 1.4
>            Reporter: Stefan Lischke
>            Priority: Minor
>         Attachments: AXIS2-3158.diff, AXIS2-3158.patch
>
>
> When using XMLBeans from commandline, i'm able to give the parameter -javaversion 1.5
and the code generated for unbounded occurrences uses typed Lists instead of Arrays. 
> I would like to have this possibility also when using xmlbeans within axis2. If i have
time, i'll look at the code to propose a solution for this. Maybe an update to xmlbeans 2.3
is enough.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message