axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Houbaux (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-3215) Strange behavior: org.apache.axis2.AxisFault: For input string: ""
Date Mon, 24 Sep 2007 10:30:50 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-3215?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12529824
] 

Patrick Houbaux commented on AXIS2-3215:
----------------------------------------

More information on this:

Just found out that if the client stub is used in a servlet context for which I managed to
clear the system property for http.proxyHost it works (meaning I don't get the For input string:
"" message anymore) and get the correct answer from the service host.

But as soon as I add the AxisServlet to my web.xml the same client fire the second exception
mentioned below (i.e. org.apache.axis2.AxisFault: Transport error: 415 Error: Unsupported
Media Type).

So I started to investigate the axis2.xml and remembered that I had set the parameter enableSwA
to true because some other services in my main web app are using this.

If I turn this to false for the client stubs I don't get anymore exceptions and I don't have
to to tweak the System.properties for the proxy host anymore.

                Options options = stub._getServiceClient().getOptions();
                options.setProperty(org.apache.axis2.Constants.Configuration.ENABLE_SWA, org.apache.axis2.Constants.VALUE_FALSE);
               
Don't know if that is the correct fix but at least I can move on now ;) ... that was a hard
one to figure out.

> Strange behavior: org.apache.axis2.AxisFault: For input string: ""
> ------------------------------------------------------------------
>
>                 Key: AXIS2-3215
>                 URL: https://issues.apache.org/jira/browse/AXIS2-3215
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>    Affects Versions: 1.3
>         Environment: OS: WindowsXP Pro Sp2
> JVM: sun jsdk 1.5.0_11
> Servlet Container: Apache Tomcat 5.5.17
> IDE: Netbeans 5.5.1
>            Reporter: Patrick Houbaux
>            Priority: Blocker
>         Attachments: stubs_skeleton.zip, test_nbproject.zip
>
>
> I have a weird problem that I am stuck with.
> Here is the situation:
> I have a web service client stub generated with wsdl2java using xmlbeans which works
ok when I used it from a standalone application.
> Now I have the need to use this client stub from an application server (i.e. tomcat +
axis2_1_3) from which I'm exposing other web services as well as this one. So for this web
service I have both the client stub and the server skeleton on the server side (the skeleton
is calling the client stub, actually passing through requests to the underlying server).
> The problem: I'm getting the following exception
>    
>         org.apache.axis2.AxisFault: For input string: "" on the client side and nothing
on the server side.
> When running the server in debug mode I found out that this exception is actually due
to a NumberFormatException thrown by the following line in org.apache.axis2.transport.http.ProxyConfiguration:
>         String port = System.getProperty(HTTP_PROXY_PORT); <-- port = ""
>         if (port != null) {
>             this.setProxyPort(Integer.parseInt(port));  <-- ERROR here
>         }
> But this did not happen when using the client stub directly from a standalone application.
> Debugging further I noticed the following difference:
> In both case the method org.apache.axis2.transport.http.AbstractHTTPSender#getHostConfiguration
is called but the following test is false in case of the standalone application and true in
case of the server application:
>         if (ProxyConfiguration.isProxyEnabled(msgCtx,targetURL)) {
>             log.debug("ProxyConfiguration");
>             ProxyConfiguration proxyConfiguration = new ProxyConfiguration();
>             proxyConfiguration.configure(msgCtx,client,config);
>         }
> So I thought that clearing the System property ("http.proxyHost") would do the trick
in the server skeleton before invoking the method from the client stub but ... this leads
to another exception (this time on the server side) which I don't really understand:
>         [INFO] Unable to sendViaPost to url[http://vivace.qub.ac.uk/MassService.asmx]
>         org.apache.axis2.AxisFault: Transport error: 415 Error: Unsupported Media Type
>         at org.apache.axis2.transport.http.HTTPSender.handleResponse(HTTPSender.java:298)
>         at org.apache.axis2.transport.http.HTTPSender.sendViaPost(HTTPSender.java:192)
>         at org.apache.axis2.transport.http.HTTPSender.send(HTTPSender.java:77)
>         at org.apache.axis2.transport.http.CommonsHTTPTransportSender.writeMessageWithCommons(CommonsHTTPTransportSender.java:327)
>         at org.apache.axis2.transport.http.CommonsHTTPTransportSender.invoke(CommonsHTTPTransportSender.java:206)
>         at org.apache.axis2.engine.AxisEngine.send(AxisEngine.java:396)
>         at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:374)
>         at org.apache.axis2.description.OutInAxisOperationClient.executeImpl(OutInAxisOperation.java:211)
>         at org.apache.axis2.client.OperationClient.execute(OperationClient.java:163)
>         at uk.ac.qub.vivace.modelservice.MassServiceStub.GetPartMass(MassServiceStub.java:250)
> I'm now short of ideas on how to interpret this and would really appreciate some help.
> Any idea? What am I missing?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message