axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikael Carlstedt (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Updated: (AXIS-2695) 'No such operation' error appears after previous successful requests
Date Fri, 07 Sep 2007 14:23:31 GMT

     [ https://issues.apache.org/jira/browse/AXIS-2695?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Mikael Carlstedt updated AXIS-2695:
-----------------------------------

    Attachment: paymentvalidation.wsdl

WSDL used for web service.

NS to package mappings:
urn\:validationapi.soap.billgate.gateway.mblox.com=com.mblox.general.serviceparameterapi.soap.paymentvalidationapi
urn\:types.soap.billgate.gateway.mblox.com=com.mblox.general.serviceparameterapi.soap.types


> 'No such operation' error appears after previous successful requests
> --------------------------------------------------------------------
>
>                 Key: AXIS-2695
>                 URL: https://issues.apache.org/jira/browse/AXIS-2695
>             Project: Axis
>          Issue Type: Bug
>          Components: Basic Architecture
>    Affects Versions: 1.4
>         Environment: Linux kernel 2.6.9-34.ELsmp
> Sun JVM 1.5.0_06-b05
> Tomcat 5.5.17
>            Reporter: Mikael Carlstedt
>         Attachments: debug_failed_request.log, debug_startup.log, paymentvalidation.wsdl
>
>
> Our Axis based SOAP server has started rejecting requests in the SOAP layer for no obvious
reason, without any changes to neither the web application nor the clients. This has happened
a couple of times before and then things have gone back to normal after a Tomcat restart,
but this time the error persists after restart, and even after reinstalling the WAR file of
the web application.
> The error message is: No such operation 'validateRequest'
> 	at org.apache.axis.providers.java.RPCProvider.getOperationDesc(RPCProvider.java:312)
>         ...
> I have enabled debug logging for org.apache.axis and captured the startup and a failed
request (to be attached). Something that caught my attention in the startup sequence was the
debug message:
> DEBUG - MessageContext.<clinit>(328) | Unable to find a temp dir with write access
> Can this have anything to do with the failure?
> For reference I am also attaching the WSDL for our web service.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message