axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Badorrek" <mbador...@avoga.com.au>
Subject RE: [AXIS2] WSA used when invoke WS inside another Web Service
Date Wed, 08 Aug 2007 06:43:57 GMT
If you look in the axis2.xml file that configures the server, is WSA engaged?

________________________________

From: Alberto Patino [mailto:pato.lukaz@gmail.com]
Sent: Wed 8/8/2007 2:39 PM
To: axis-dev@ws.apache.org
Subject: [AXIS2] WSA used when invoke WS inside another Web Service



Hi guys!

I wrote an axis2 web service, so inside of the skeleton I inserted
code to invoke another web service. Basically I get a new instance of
the Stub Class, fiil the ADBBean with data to pass this data as the
parameter and invoke the operation, but I realized something amazing
;-p the Stub instance determines that the invocation will be using the
WSA spec!!!

If I run the client in standalone mode the invokation is a normal SOAP
message with no WSA special tags. Debugging a little bit the code, I
realized that the addressing module is engaged to the operation and
the AxisService inside the Stub Class, but I coulnd't find out what is
the reason of this behavior.

Could someone enlighten me?

Thanks!
--
Don't be evil!!!

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org




Mime
View raw message