axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Piotr Szarwas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-2925) Axis doesn't use params from axis2.xml
Date Fri, 03 Aug 2007 13:52:52 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-2925?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12517533
] 

Piotr Szarwas commented on AXIS2-2925:
--------------------------------------

Hi,

I used -Daxis2.xml=<replace-with-path-to-your-axis2.xml> and it was working
ok, because other parameters were taken from my config file.

Piotr.



> Axis doesn't use params from axis2.xml
> --------------------------------------
>
>                 Key: AXIS2-2925
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2925
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: kernel
>    Affects Versions: 1.2
>         Environment: System (uname):
> Linux 2.6.17-11mdv #1 SMP, 
> Java (java -version):
> java version "1.4.2_12"
> Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_12-b03)
> Java HotSpot(TM) Client VM (build 1.4.2_12-b03, mixed mode)
>            Reporter: Piotr Szarwas
>            Assignee: sumedha rubasinghe
>            Priority: Minor
>             Fix For: 1.2
>
>
> Hi,
> I'm using axis in following way:
> SOAPConnectionFactory connectionFactory = SOAPConnection.newInstance()
> SOAPConnection soapConnection = connectionFactory.createConnection();
> response = soapConnection.call(message, wmHostInfo.getUrl());
> soapConnection.close();
> and I have following axis2.xml:
> <transportSender name="" class="org.apache.axis2.transport.http.CommonsHTTPTransportSender">
>      <parameter name="PROTOCOL" locked="false">HTTP/1.1</parameter>
>      <parameter name="SO_TIMEOUT" locked="false">12000</parameter>
>      <parameter name="CONNECTION_TIMEOUT" locked="false">12000</parameter>
>  </transportSender>
> I found that axis never use my params (I also tried to put then in different parts of
config file). AIxis always use DEFAULT_TIMEOUT_MILLISECONDS from Options class.  I thing problem
apeare in HttpSender in line 285, here I always getting DEFAULT_TIMEOUT_MILLISECONDS, because
options doesn't has setup params from config file. 
> Piotr

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message