axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yattie Smith (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-3162) tcp transport problem: multithread blocking sending doesn't work
Date Thu, 30 Aug 2007 01:24:31 GMT
tcp transport problem: multithread blocking sending doesn't work
----------------------------------------------------------------

                 Key: AXIS2-3162
                 URL: https://issues.apache.org/jira/browse/AXIS2-3162
             Project: Axis 2.0 (Axis2)
          Issue Type: Bug
          Components: transports
    Affects Versions: 1.2
         Environment: jdk1.5, axis2 1.2, tomcat 5.0
            Reporter: Yattie Smith


I create a webservices to send datas, and http,jms transport works fine with multithread sending,
but not for tcp.
TCP uses ws-addressing in both client and server sides, and it works fine in single thread.
In the case of multithread,
e.g., 
1. a thread T1 created to send data D1, use a ServiceClient object in blocking way(sendReceive())
2. meanwhile, another thread T2 created to send data D2
3. T1 sent the data and has not received the reply;(need more time)
4. T2 sent the data and received the reply;(T2 works OK)
5. T1 throws a Exception: Socket output is already shutdown

I use the seperator listener by options.setUseSeparateListener(true) and similarlly "socket
shutdown" exception
My question is:
when using two seperate ServiceClient, there should be two socket connection. It works fine
for http and jms, but why not work for
tcp? Is there something I missed when engaged ws-addressing or some bugs there?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message