axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tony Dean" <Tony.D...@sas.com>
Subject RE: [Axis2] service mapping
Date Sat, 07 Jul 2007 19:31:51 GMT
any response from the axis2 team on this?


________________________________

	From: Tony Dean [mailto:Tony.Dean@sas.com] 
	Sent: Monday, July 02, 2007 2:20 PM
	To: axis-dev@ws.apache.org
	Subject: RE: [Axis2] service mapping
	
	
	This refers to the directory under WEB-INF that contains webservice artifacts.  That naming
hierarchy is fine.  I'm just wondering why the webservice client has to specify the full name
'context/services/myService' instead of 'context/myService'.  The axis2 engine needs to know
this, but the client doesn't.
	 
	Thanks.


________________________________

		From: Mark Badorrek [mailto:mbadorrek@avoga.com.au] 
		Sent: Sunday, July 01, 2007 11:01 PM
		To: axis-dev@ws.apache.org
		Subject: RE: [Axis2] service mapping
		
		
		Hi Tony,
		 
		You are correct - out of the box, this is the default behaviour.
		 
		If you want to change it, look for the following line the conf/axis2.xml, uncomment it,
and change to whatever you want:
		 
		<!--<parameter name="ServicesDirectory">service</parameter>-->

		Cheers,
		 
		Mark B

		 
________________________________

		From: Tony Dean [mailto:Tony.Dean@sas.com]
		Sent: Mon 7/2/2007 10:41 AM
		To: axis-dev@ws.apache.org
		Subject: RE: [Axis2] service mapping
		
		

		'services' in the url mapping seems to be required.  that is 'context/services/myService'
works, but 'context/myService' does not.  is that expected? why?
		
		> -----Original Message-----
		> From: Tony Dean [mailto:Tony.Dean@sas.com]
		> Sent: Thursday, June 28, 2007 6:54 PM
		> To: axis-dev@ws.apache.org
		> Subject: [Axis2] service mapping
		>
		> Hi,
		>
		> I changed my web.xml servlet mapping to map all requests to
		> the AxisServlet:
		>
		> <servlet-mapping>
		>    <servlet-name>AxisServlet</servlet-name>
		>    <url-pattern>/*</url-pattern>
		> </servlet-mapping>
		>
		> I'm now able to query for my wsdl as
		> http://host:port/context/myService?wsdl.
		> But, I get service not found when I try to execute it.  I
		> have to specify
		> http://host:port/context/services/myService?wsdl in order for
		> axis2 to find my service.
		>
		> Is this correct?  Is there a way to avoid the extra
		> 'services' path in the url mapping?
		>
		> Thanks.
		>
		> Tony Dean
		> SAS Institute Inc.
		> 919.531.6704
		> tony.dean@sas.com
		>
		> SAS... The Power to Know
		> http://www.sas.com
		>
		>
		> ---------------------------------------------------------------------
		> To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
		> For additional commands, e-mail: axis-dev-help@ws.apache.org
		>
		>
		
		---------------------------------------------------------------------
		To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
		For additional commands, e-mail: axis-dev-help@ws.apache.org
		
		


Mime
View raw message