axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjiva Weerawarana <sanj...@opensource.lk>
Subject Re: [Axis2] WSDL20ToAxisServiceBuilder client support question
Date Tue, 17 Jul 2007 00:07:39 GMT
No this appears to be an oversight .. it works the same way for WSDL2 too 
in Axis2- its really an Axis2 thing to think about how messages go back 
and forth.

My guess would be Keith hasn't actually tried creating a ServiceClient 
from a WSDL 2.0 document :).

Your help to fix it would be appreciated ..

Sanjiva.

David Illsley wrote:
> Hi all,
> I'm trying to use the WSDL2 support in SVN trunk and I'm running into
> a problem when writing a client. I'm using WSDL20ToAxisServiceBuilder
> to build the AxisService object (with isServerSide set to false) yet
> the AxisService has the WSDL2 in-out MEP set on it which isn't
> supported in the Axis2 ServiceClient (it does out-in). The
> WSDL11ToAxisServiceBuilder swaps the MEP round based on the value of
> isServerSide which is what makes this work but the WSDL 2 version
> doesn't seem to.
> 
> Is this an oversight in WSDL20ToAxisServiceBuilder, or does it work
> differently for WSDL 2.0?
> Cheers,
> David
> 

-- 
Sanjiva Weerawarana, Ph.D.
Founder & Director; Lanka Software Foundation; http://www.opensource.lk/
Founder, Chairman & CEO; WSO2, Inc.; http://www.wso2.com/
Director; Open Source Initiative; http://www.opensource.org/
Member; Apache Software Foundation; http://www.apache.org/
Visiting Lecturer; University of Moratuwa; http://www.cse.mrt.ac.lk/

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message