axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicholas L Gallardo <nlgal...@us.ibm.com>
Subject Re: [Axis2] Dispatchers in org.apache.axis2.engine package
Date Mon, 25 Jun 2007 14:43:42 GMT





+1  That sounds like the best solution here.  I agree with David's comment
that user's shouldn't be accessing anything inside of the .engine package
either.  If it's part of an official API, move it to other package.

Dims, what about adding something that issues a deprecation warning when
the dispatcher loaded contains the "org.apache.axis2.engine" package.
Depending on how long the internal is between 1.4 and 1.3, you could then
remove it in the next release or wait one more depending on how long you
wanted to support it.

Regards,

-Nick



                                                                           
             "Davanum                                                      
             Srinivas"                                                     
             <davanum@gmail.co                                          To 
             m>                        "Afkham Azeez" <afkham@gmail.com>   
                                                                        cc 
             06/25/2007 09:29          axis-dev@ws.apache.org              
             AM                                                    Subject 
                                       Re: [Axis2] Dispatchers in          
                                       org.apache.axis2.engine package     
             Please respond to                                             
             axis-dev@ws.apach                                             
                   e.org                                                   
                                                                           
                                                                           
                                                                           




So, if i come up with a technique for backward compat w/o touching the
old axis2.xml files, that should be ok right?

thanks,
dims

On 6/25/07, Afkham Azeez <afkham@gmail.com> wrote:
> I am not in favor of this change. This is going to annoy a large number
of
> users who may want to migrate from Axis2 1.2 to 1.3. They will have to
edit
> all of their axis2.xml files. They may go thorugh a lot of pain to figure
> out that the package has to be changed in their axis2.xml files. The last
> thing we need at the moment is unhappy users. This is a mistake we may
have
> to live with.
>
> -- Azeez
>
>
> On 6/24/07, Davanum Srinivas <davanum@gmail.com> wrote:
> >
> > Team,
> >
> > Anyone object to moving the following classes to
> org.apache.axis2.dispatchers?
> >
> > AddressingBasedDispatcher.java
> > HTTPLocationBasedDispatcher.java
> > InstanceDispatcher.java
> > RequestURIBasedDispatcher.java
> > RequestURIOperationDispatcher.java
> > SOAPActionBasedDispatcher.java
> > SOAPMessageBodyBasedDispatcher.java
> >
> > Leaving AbstractDispatcher.java as-is in org.apache.axis2.engine
> >
> > thanks,
> > dims
> >
> > --
> > Davanum Srinivas :: http://davanum.wordpress.com
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> axis-dev-unsubscribe@ws.apache.org
> > For additional commands, e-mail: axis-dev-help@ws.apache.org
> >
> >
>
>
>
> --
> Thanks
> Afkham Azeez
>
> http://www.wso2.org
> GPG Fingerprint: 643F C2AF EB78 F886 40C9  B2A2 4AE2 C887 665E 0760


--
Davanum Srinivas :: http://davanum.wordpress.com

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message