axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AXIS2-2665) WS-Addressing Action element is ignored.
Date Fri, 08 Jun 2007 01:15:26 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-2665?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Davanum Srinivas resolved AXIS2-2665.
-------------------------------------

    Resolution: Cannot Reproduce

> WS-Addressing Action element is ignored.
> ----------------------------------------
>
>                 Key: AXIS2-2665
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2665
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>    Affects Versions: 1.2
>         Environment: Axis1.2/jdk1.5/windows
>            Reporter: Rakesh
>            Assignee: Davanum Srinivas
>
> Hi,
> We are currently using Axis2 1.0 for our project, and are planning to move to axis2 1.2.
While attempting I noticed the following problems.
> Problem: The wsa:Action tag is not parsed as it used to be in the previous versions..
> Details:
> I have the addressing module engaged, and I invoke the service in the following fashion

> URL: http://...../services/<<ServiceName>>/
> Envelop:
> <?xml version='1.0' encoding='UTF-8'?> 
> <soapenv:Envelope 
> xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
> xmlns:wsa="http://www.w3.org/2005/08/addressing" 
> xmlns:xsi="http://www.w3.org/1999/XMLSchema-instance" 
> xmlns:xsd="http://www.w3.org/1999/XMLSchema"> 
> <soapenv:Header> 
> <wsa:MessageID>urn:uuid:22347A22E831E85ACF11689672899211</wsa:MessageID>

> <wsa:To>/axis2/services/<<SERVICE_NAME>></wsa:To> 
> <wsa:Action>urn:OperationName</wsa:Action> 
> </soapenv:Header> 
> <soapenv:Body> 
> <op:OperationName xmlns:op="<<THE URL>>"> 
> <PARAM1>XYZ</PARAM1> 
> </op:OperationName> 
> </soapenv:Body> 
> </soapenv:Envelope>
> The response is that the EPR is not found, even though we have the wsa:Action tag present.
> I know this envelop (with WS-Addressing) used to work fine in 1.0/1.1.1 versions. Is
this still supported or is this a bug.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message