axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amila Chinthaka Suriarachchi (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AXIS2-1986) axis looking in wrong place for generated ADB factory
Date Fri, 15 Jun 2007 23:27:25 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-1986?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Amila Chinthaka Suriarachchi resolved AXIS2-1986.
-------------------------------------------------

    Resolution: Fixed

it seems that this sample is already removed. please check with the axis2 1.2 and if the bug
still there please reopen the jira. 
please mention the steps to reproduce the bug.

> axis looking in wrong place for generated ADB factory
> -----------------------------------------------------
>
>                 Key: AXIS2-1986
>                 URL: https://issues.apache.org/jira/browse/AXIS2-1986
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: adb
>    Affects Versions: 1.1.1
>         Environment: linux
>            Reporter: chad davis
>            Assignee: Amila Chinthaka Suriarachchi
>            Priority: Blocker
>             Fix For: 1.3
>
>
> I've created and partially successfully run the ADB client from the
> user guide.  See following link:
> http://ws.apache.org/axis2/1_1_1/userguide-creatingclients.html#adb
> My Problem:
> I've got 3 of four requests / responses behaving properly.  On the
> fourth, the multiple parameters in both directions one, it blows up
> with a classnotfound on the MultipleParametersAddItemRequest$Factory
> class.  This class does exist on the classpath.  The problem is that
> it is an inner class, as created by the wsdl2java with ADB set.  It
> seems that axis2 is looking for the the MPARequest as a toplevel
> class?  Below is the stack trace.  How is this generated Request any
> different than the ones for the first three requests?
> calling do in only
> done
> calling two way echo
> Knock Knock
> calling no parameters.
> org.apache.axis2.axis2userguide.Axis2UserGuideServiceStub$NoParametersResponse@1971afc
> calling mulitp param
> org.apache.axis2.AxisFault: java.lang.NoClassDefFoundError:
> org/apache/axis2/axis2userguide/MultipleParametersAddItemRequest$Factory
>        at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:271)
>        at org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisOperation.java:202)
>        at org.apache.axis2.axis2userguide.Axis2UserGuideServiceStub.MultipleParametersAddItem(Axis2UserGuideServiceStub.java:398)
>        at org.apache.axis2.axis2userguide.TestClient.multipleParameters(TestClient.java:89)
>        at org.apache.axis2.axis2userguide.TestClient.main(TestClient.java:26)

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message