axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "J. Allen (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-2674) NullPointerException in AxisServlet doPost method
Date Thu, 07 Jun 2007 15:50:26 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-2674?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

J. Allen updated AXIS2-2674:
----------------------------

    Attachment: nextran.zip

A zipped version of the WAR file is attached.  2 files were removed to get under the 10MB
limit.  The 2 files removed are:
xalan-2.7.0.jar
xbean-2.2.0.jar
Those should be added back to the WEB-INF/lib directory.

Axis2 is embedded in the WAR file so it can simply be placed in the Tomcat 5.5 webapps directory
for testing.

> NullPointerException in AxisServlet doPost method
> -------------------------------------------------
>
>                 Key: AXIS2-2674
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2674
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: databinding, wsdl
>    Affects Versions: 1.2
>         Environment: Eclipse WTP on Windows XP using Tomcat 5.5.20 as the app.server
and SOAPUI version 1.71 as the client
>            Reporter: J. Allen
>         Attachments: imageViewService.wsdl, nextran.zip, wtp1.jpg, wtp2.jpg
>
>
> Axis 1.2 was added to a web application.  The Java class stubs were generated using he
WSDL2Java tool using XMLBeans data binding.
> Everything appears to be configured right since the methods in the skeleton class are
being invoked correctly.
> The echo method works fine.  However, when I try another operation I always get a NullPointerException
thrown from the doPost method of the org.apache.axis2.transport.http.AxisServlet class.  The
error says only:
> May 8, 2007 1:40:01 PM org.apache.axis2.transport.http.AxisServlet doPost
> SEVERE: java.lang.NullPointerException
> The method in the skeleton class returns without errors.
> The error was traced using the Eclipse WTP debugger to the statement in the org.apache.axis2.transport.http.HTTPTransportUtilis
class within the following "if" condition:
> if ((msgContext.getEnvelope() == null) && soapVersion != VERSION_SOAP11) {
>   msgContext.setEnvelope(new SOAP12Factory().getDefaultEnvelope());
> }
> The msgContext.getEnvelope method returns an envelop and is therefore not null.  The
soapVersion has a value of 1 and the VERSION_SOAP11 final variable also has a value of 1.
> The NPE happens immediately when I try to step into the SOAP12Factory().getDefaultEnvelope()
method.
> The request used is below:
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:imag="http://ws.estesexpress.com/imageview">
>    <soapenv:Header>
>       <imag:auth>
>          <imag:user>u</imag:user>
>          <imag:password>p</imag:password>
>       </imag:auth>
>    </soapenv:Header>
>    <soapenv:Body>
>       <imag:imgRequest>
>          <imag:requestID>20070512</imag:requestID>
>          <pro>1234567890</pro>
>          <document>BOLA</document>
>       </imag:imgRequest>
>    </soapenv:Body>
> </soapenv:Envelope>
> Is there a way to attach the WAR file to the bug?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message