axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-2758) MissingResourceException on execution client with Axis2.1.2
Date Wed, 06 Jun 2007 18:39:26 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-2758?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12502023
] 

Davanum Srinivas commented on AXIS2-2758:
-----------------------------------------

MissingResourceException was caused by a missing resource.properties in the addressing mar.
Something else you did caused the problem to go way. there is no requirement for elementFormDefault
to be qualified. I think you added a wsaw:Action in your wsdl (and then generated code) or
you specified the ws addressing action somehow. if you see it again, please holler and upload
your wsdl that fails.

thanks,
dims

> MissingResourceException on execution client with Axis2.1.2
> -----------------------------------------------------------
>
>                 Key: AXIS2-2758
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2758
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>    Affects Versions: 1.2
>            Reporter: Stephane Roy
>
> I developed a web service with Axis2.1.1.1 in adb mode and everything works fine.
> I tried to migrate this web service in Axis2.1.2 but it's not working.
> I generated the code in adb mode for the server and deployed it. I generated the code
in adb mode for the client and I managed to compile the code. Now when I start the client,
I have this error:
> org.apache.axis2.AxisFault: java.util.MissingResourceException: Can't find resource for
bundle org.apache.axis2.i18n.ProjectResourceBundle, key spec.FAULT_ACTION_NOT_SUPPORTED_REASON
>   at org.apache.axis2.util.Utils.getInboundFaultFromMessageContext(Utils.java:434)
>   at org.apache.axis2.description.OutInAxisOperationClient.send(OutInAxisOperation.java:373)
>   at org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisOperation.java:294)
>   at my.package.myServiceStub.myMethod(myServiceStub.java:173)
>   ...
> After analysis, I found a workaround to my problem. By analysing the web service example
of the Axis2 tutorial, I noticed that the WSDL included this definition:
> >>>
> elementFormDefault="qualified"
> >>>
> Since I didn't have it in my web service, I added this definition in my XSD and the NullPointerException
doesn't not occur anymore !
> If this definition is required in the XSD schema, Axis2 documentation should mention
it.
> Thanks in advance.
> PS: This problem has been submitted to the User mailing list:
> http://marc.info/?l=axis-user&m=117930719429534&w=2 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message