axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-1473) org.apache.axis2.AxisFault: Connection reset - connections are not closing for long time
Date Thu, 03 May 2007 11:20:15 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-1473?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chris updated AXIS2-1473:
-------------------------

    Attachment: AbstractHTTPSender.java

Patched file with work-around which seems to deal with .net's habit of closing the HTTP connection
unexpectedly.

> org.apache.axis2.AxisFault: Connection reset - connections are not closing for long time
> ----------------------------------------------------------------------------------------
>
>                 Key: AXIS2-1473
>                 URL: https://issues.apache.org/jira/browse/AXIS2-1473
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: client-api, codegen
>    Affects Versions: nightly
>         Environment: Client in Windows XP SP2, jdk 1.5, Axis2 1.1 Nightly build(October
20, 2006), Microsoft SQL Reporting Services 2005 in Windows XP, JVM Heap settings : -Xrs -Xmx700M
-Xms512M.., Memory :1 GB
>            Reporter: GNANASEKARAN VINAYAKAMURTHY
>         Assigned To: Deepal Jayasinghe
>            Priority: Critical
>         Attachments: AbstractHTTPSender.java, Connection-reset-exeption.txt, netstat-output.doc,
reportexecution2005.wsdl, reportservice2005.wsdl, SSRS-Main.zip
>
>
> Getting connection reset problem in Axis2 1.1 Nightly, when I try to make web service
calls to .Net client (MS Reporting services in XP) again and again.... But it works fine when
called at initial couple of times... I think system breaks, when we make web service call
at 5th consecutive time. 
> I am trying to create web application with axis2, where I could show all the reports
and folders from MS reporting services.
> Axis2 client and .Net web service server(MS Reporting services) are running on windows
platform and I just tried using 'netstat -a' in the system, where my Axis2 client is running
and  found that connections made by Axis2 were not closing for long time...... I think Axis2
is not closing the socket connections after end of web service calls in client side.
> I have also attached the following with this,
> 1. Netstat output
> 2. Exception stack trace
> 3. wsdl files
> 4. Source code
> Please let me know about how could we close connections completely from Axis2 or how
to fix this?
> Thanks,

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message