axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lahiru Sandakith (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-2523) Axis Service Archiver : aar Eclipse plugin cannot be installed
Date Sat, 05 May 2007 04:44:15 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-2523?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12493852
] 

Lahiru Sandakith commented on AXIS2-2523:
-----------------------------------------

Please use the 1.2 plugin http://www.apache.org/dyn/mirrors/mirrors.cgi/ws/axis2/tools/1_2/axis2-eclipse-service-archiver-wizard-1.2.zip
these is a know issue in the 1.1.1 plugin with the jdk1.4.x , it works with 1.5.x 



> Axis Service Archiver : aar Eclipse plugin cannot be installed
> --------------------------------------------------------------
>
>                 Key: AXIS2-2523
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2523
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: Tools
>    Affects Versions: 1.1.1
>         Environment: Win 2000 / Eclipse SDK 3.2.0 / Java JDK 1.4.2
>            Reporter: Benjamin Pochat
>         Assigned To: Lahiru Sandakith
>
> Hi,
> I tried to install the Eclipse plugin to generate aar files. It seems the installation
is impossible with Eclipse 3.2.0.
> See the following Eclipse log file :
> !ENTRY org.eclipse.osgi 4 0 2007-04-13 11:21:40.122
> !MESSAGE An error occurred while automatically activating bundle Axis_Service_Archiver
(478).
> !STACK 0
> org.osgi.framework.BundleException: The activator org.apache.axis2.tool.service.eclipse.plugin.ServiceArchiver
for bundle Axis_Service_Archiver is invalid
> 	at org.eclipse.osgi.framework.internal.core.AbstractBundle.loadBundleActivator(AbstractBundle.java:141)
> 	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:966)
> 	at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:317)
> 	at org.eclipse.osgi.framework.internal.core.AbstractBundle.start(AbstractBundle.java:256)
> 	at org.eclipse.core.runtime.internal.adaptor.EclipseLazyStarter.preFindLocalClass(EclipseLazyStarter.java:86)
> 	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:409)
> 	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:188)
> 	at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:339)
> 	at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:391)
> 	at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:352)
> 	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
> 	at java.lang.ClassLoader.loadClass(Unknown Source)
> ....
> Caused by: java.lang.UnsupportedClassVersionError: org/apache/axis2/tool/service/eclipse/plugin/ServiceArchiver
(Unsupported major.minor version 49.0)
> 	at java.lang.ClassLoader.defineClass0(Native Method)
> 	at java.lang.ClassLoader.defineClass(Unknown Source)
> 	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.defineClass(DefaultClassLoader.java:160)
> 	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.defineClass(ClasspathManager.java:498)
> 	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findClassImpl(ClasspathManager.java:468)
> 	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClassImpl(ClasspathManager.java:427)
> 	at org.eclipse.osgi.baseadaptor.loader.ClasspathManager.findLocalClass(ClasspathManager.java:410)
> 	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.findLocalClass(DefaultClassLoader.java:188)
> 	at org.eclipse.osgi.framework.internal.core.BundleLoader.findLocalClass(BundleLoader.java:339)
> 	at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:391)
> 	at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:352)
> 	at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
> 	at java.lang.ClassLoader.loadClass(Unknown Source)
> ...
> If you need some additional information about the configuration, please do not hesitate.
> Benjamin

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message