axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pankaj Kumar (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Commented: (AXIS-2462) Axis is not JDK1.5 compliant
Date Mon, 14 May 2007 08:42:17 GMT

    [ https://issues.apache.org/jira/browse/AXIS-2462?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12495515
] 

Pankaj Kumar commented on AXIS-2462:
------------------------------------

When generating java code using wsdl2java, I have these lines:

       oper.setStyle(org.apache.axis.enum.Style.RPC);
      oper.setUse(org.apache.axis.enum.Use.ENCODED);

this lines gives compilation errors in my setup due to which I am not able to run my sample
code that I intened to run in tomcat.

Kindly provide pointers in this regards. Do I need to use JDK1.4 so that I do not encounter
similar issue.

Thanks  & Regards,
pankaj

> Axis is not JDK1.5 compliant
> ----------------------------
>
>                 Key: AXIS-2462
>                 URL: https://issues.apache.org/jira/browse/AXIS-2462
>             Project: Axis
>          Issue Type: Bug
>          Components: Deployment / Registries
>    Affects Versions: 1.3
>         Environment: Java 1.5
>            Reporter: amit
>
> Axis has a package name which conflicts with the Java 1.5 'enum' keyword.  org.apache.axis.enum.*
> Simple change is required or else how are we supposed to use it on 1.5 ???

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message