axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brad (JIRA)" <>
Subject [jira] Commented: (AXIS2-2638) stub sending text/xml instead of application/x-www-form-urlencoded
Date Thu, 10 May 2007 09:30:15 GMT


Brad commented on AXIS2-2638:

Ok, I'm not sure I understand what your point is then. Sorry for being a bit slow, I'm pretty
new to Axis.

Originally I didn't use the option "-pn LookupUKSoap" but I wasn't having any success so I
thought best to specify one of the three ports in the WSDL. From what you are saying it sounds
like you think I shouldn't be generating code for the SOAP binding. Is that a correct because
I was pretty sure that was what I wanted to do in the first place!

I realise I'm probably missing something fundamental here but I would like to get this resolved.
I've generated stubs and used them to call the service which returns a 500 error about the
content type. I tried setting the content type in the options but it doesn't filter down to
the transport layer (commons-http). Isn't that the essence of the problem?

Once again, apologies for not being on the same wavelength here. 

> stub sending text/xml instead of application/x-www-form-urlencoded
> ------------------------------------------------------------------
>                 Key: AXIS2-2638
>                 URL:
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: client-api
>    Affects Versions: 1.2, 1.1.1
>         Environment: JDK 1.4.2._13
>            Reporter: Brad
>         Assigned To: Keith Godwin Chapman
>         Attachments: postcodeAnywhere.wsdl
> Hi all,
> I've generated client classes from a WSDL doc using the following command line:
> wsdl2java.bat -pn xxxxxSoap -o src -d xmlbeans -uri xxxxxxx.wsdl
> It all works fine but when I try to invoke the remote service I get
> the following error:
> org.apache.axis2.AxisFault: Transport error 500 . Error Message is
> Request format is invalid: text/xml; charset=UTF-8.
> ;
> Which is fair enough as the server is expecting content type
> "application/x-www-form-urlencoded", as specified in the WSDL:
> <wsdl:operation name="xxxxx">
>    <http:operation location="/xxxxx"/>
>        <wsdl:input>
>             <mime:content type="application/x-www-form-urlencoded"/>
>        </wsdl:input>
>        <wsdl:output>
>            <mime:mimeXml part="Body"/>
>        </wsdl:output>
> </wsdl:operation>
> Is there any way to over ride the content type? I tried this:
>                        Options opts = new Options();
>                        opts.setProperty(Configuration.CONTENT_TYPE,
>                        opts.setProperty(HTTPConstants.CHUNKED, Boolean.FALSE);
>                        client.setOptions(opts);
> I get the same error though. I tried client.setOverrideOptions(opts)
> as well but no change. Using them both causes a StackOverflowError :-)
> Any help greatly appreciated!
> Cheers,
> Brad.
> ----------------------------------------------------------------------------------------------------------------------------------
> Brad,
> Could you please log a bug in JIRA and upload your wsdl. Something is
> seriously wrong esp with the StackOverflowError.
> thanks,
> dims

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message