axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Fabrizio Vizzari (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-2713) Invocation target exception invoking String[] element nillable
Date Fri, 25 May 2007 13:17:16 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-2713?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12499080
] 

Fabrizio Vizzari commented on AXIS2-2713:
-----------------------------------------

Thanks dims for your suggestion,

I know that minOccurs is 1 by default. But minOccurs means that the tag can be omitted in
the envelope.

In my envelope as you can see i pass explicitly "zone" and "parole chiave" but i leave them
empty. I also tried to explicitly set them to nil.
I tried now to avoid to pass the two elements above and the request does not generate the
problem.

But this behaviour is very strange because my server and 3P server with the same envelope
and tha same AXIS2 version and a wsdl very similar works in two different ways.

In addition of that the wsdl is auto-generated and i really can't manually edit the wsdl every
time there is a change in the schema.

Thanks again,
Fabrizio

> Invocation target exception invoking String[] element nillable
> --------------------------------------------------------------
>
>                 Key: AXIS2-2713
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2713
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: databinding, wsdl
>    Affects Versions: 1.2
>         Environment: Both winXP and Linux.
> Both application server Tomcat and JBoss
>            Reporter: Fabrizio Vizzari
>         Attachments: 3P_wsdl.wsdl, my_wsdl.wsdl
>
>
> Hi,
> i have a wsdl generated from a third part (with Axis2 1.2). I attach it with the name
3P_wsdl.wsdl
> I used this wsdl to generate my client (ADB) and everything works.
> I need also to have a server side webservice with the same object generated in the previous
phase. I attach the resoulting wsdl with the name my_wsdl.wsdl.
> If i try to invoke my webservice i have this exception:
> org.apache.axis2.AxisFault: InvocationTargetException : java.lang.reflect.InvocationTargetException
> 	at org.apache.axis2.databinding.utils.BeanUtil.deserialize(BeanUtil.java:391)
> 	at org.apache.axis2.databinding.utils.BeanUtil.deserialize(BeanUtil.java:372)
> 	at org.apache.axis2.databinding.utils.BeanUtil.processObject(BeanUtil.java:642)
> 	at org.apache.axis2.databinding.utils.BeanUtil.ProcessElement(BeanUtil.java:590)
> 	at org.apache.axis2.databinding.utils.BeanUtil.deserialize(BeanUtil.java:526)
> 	at org.apache.axis2.rpc.receivers.RPCUtil.processRequest(RPCUtil.java:119)
> 	at org.apache.axis2.rpc.receivers.RPCMessageReceiver.invokeBusinessLogic(RPCMessageReceiver.java:113)
> 	at org.apache.axis2.receivers.AbstractInOutSyncMessageReceiver.receive(AbstractInOutSyncMessageReceiver.java:39)
> 	at org.apache.axis2.engine.AxisEngine.receive(AxisEngine.java:143)
> 	at org.apache.axis2.transport.http.HTTPTransportUtils.processHTTPPostRequest(HTTPTransportUtils.java:229)
> 	at org.apache.axis2.transport.http.AxisServlet.doPost(AxisServlet.java:102)
> 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
> 	at javax.servlet.http.HttpServlet.service(HttpServlet.java:802)
> 	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:252)
> 	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:173)
> 	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:213)
> 	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
> 	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
> 	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
> 	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
> 	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
> 	at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:869)
> 	at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:664)
> 	at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
> 	at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
> 	at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
> 	at java.lang.Thread.run(Unknown Source)
> I noticed tha the problem is caused by the elements "zone" and "parole chiave" that i
can't pass nil or empty string also if are declared nillable in the wsdl.
> The soap envelope passed from client to server is:
> <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://server.ws.prenotazionicertificati.covr.bo.tos.lutech.it/xsd"
xmlns:xsd1="http://webServices.prenotazioni.intesys.it/xsd">
>    <soapenv:Header/>
>    <soapenv:Body>
>       <xsd:elencoCertificati>
>          <xsd:input>
>             <xsd1:richiesta>
>                <xsd1:categoria></xsd1:categoria>
>                <xsd1:dimensionePagina>10</xsd1:dimensionePagina>
>                <xsd1:numeroPagina>1</xsd1:numeroPagina>
>                <xsd1:ordinamenti>
>                   <xsd1:tipo></xsd1:tipo>
>                   <xsd1:verso></xsd1:verso>
>                </xsd1:ordinamenti>
>                <xsd1:paroleChiave></xsd1:paroleChiave>
>                <xsd1:periodiDisponibilita>
>                   <xsd1:fine></xsd1:fine>
>                   <xsd1:inizio></xsd1:inizio>
>                </xsd1:periodiDisponibilita>
>                <xsd1:soggettoOrganizzatore></xsd1:soggettoOrganizzatore>
>                <xsd1:zone></xsd1:zone>
>             </xsd1:richiesta>
>             <xsd1:MY_QNAME></xsd1:MY_QNAME>
>          </xsd:input>
>       </xsd:elencoCertificati>
>    </soapenv:Body>
> </soapenv:Envelope>
> The same identical envelope used to invoke the 3P wsdl does not generate any problem.
> Which could be the problem ?
> Thank you
> Fabrizio

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message