axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nikolay Gorylenko (JIRA)" <j...@apache.org>
Subject [jira] Created: (AXIS2-2551) CDATA section escaping while ServiceClient.sendReceive()
Date Tue, 17 Apr 2007 18:57:15 GMT
CDATA section escaping while ServiceClient.sendReceive()
--------------------------------------------------------

                 Key: AXIS2-2551
                 URL: https://issues.apache.org/jira/browse/AXIS2-2551
             Project: Axis 2.0 (Axis2)
          Issue Type: Bug
          Components: client-api
    Affects Versions: 1.1
         Environment: > java -version
java version "1.5.0_08"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_08-b03)
Java HotSpot(TM) Client VM (build 1.5.0_08-b03, mixed mode, sharing)

> ps ax | grep jboss 
30186 ?        S      0:00 /bin/sh /opt/jboss/bin/run.sh -c default
30215 ?        Sl     3:29 /usr/lib/jvm/java-1.5.0-sun/bin/java -Dprogram.name=run.sh -server
-Xdebug -Xnoagent -Djava.compiler=NONE -Xrunjdwp:transport=dt_socket,address=127.0.0.1:53761,suspend=y,server=n
-Xms512m -Xmx1024m -Djava.endorsed.dirs=/opt/jboss/lib/endorsed -classpath /opt/jboss/bin/run.jar:/usr/lib/jvm/java-1.5.0-sun/lib/tools.jar
org.jboss.Main -c default


            Reporter: Nikolay Gorylenko


21:24 -!- Channel #apache-axis created Sun Nov 26 08:43:10 2006
21:24 -!- Irssi: Join to #apache-axis was synced in 0 secs
21:25 < n0mer> hello
21:26 < n0mer> does anyone know why <![CDATA[ content might disappear when 
               invoke ServiceClient's sendReceive?
21:27 < n0mer> this is a part of OMElement passed as param: 
               "<ns1:param0><![CDATA[<?xml version="1.0" encoding="UTF-8" 
               standalone="yes"?>"
21:29 < n0mer> but SOAPMonitor see this request as following: 
               <ns1:param0>&lt;?xml version="1.0" encoding="UTF-8" 
               standalone="yes"?>&lt;
21:30 < n0mer> param0 is created this way: OMElement param0 = 
               factory.createOMElement("param0", ns); OMNode cdata = 
               factory.createOMText(param0,content.getText(), 
               XMLStreamConstants.CDATA); request.addChild(param0);
21:31 < davanum> n0mer: that's a definite bug. please create a bug report with 
                 your code


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message