axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven E. Harris (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-2534) WSDL2Java generates invalid Addressing action header (wsa:Action) of ""
Date Wed, 25 Apr 2007 20:14:15 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-2534?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12491755
] 

Steven E. Harris commented on AXIS2-2534:
-----------------------------------------

Has there been any movement on this? Discussion on the axis-user list suggests that the original
cited for not attempting to fix this soon was based on a mistaken assumption -- namely, that
wsa:Action should be based on a binding rather than an abstract interface.

In any case, even just restoring the old "urn:<mangled operation name>" format would
be useful. The currently-emitted "\"\" is defeating my generated stubs and services.xml files,
requiring me to edit both by hand.

> WSDL2Java generates invalid Addressing action header (wsa:Action) of ""
> -----------------------------------------------------------------------
>
>                 Key: AXIS2-2534
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2534
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: codegen
>    Affects Versions: nightly
>         Environment: NA
>            Reporter: Steven E. Harris
>            Priority: Minor
>
> Running wsdl2java against a WSDL 2.0 file, I find the following line in my generated
client stub:
>   _operationClient.getOptions().setAction("\"\"");
> This line appears once for each synchronous operation, and once for each asynchronous
operation. At runtime, it produces the following header in the outgoing messages (with the
addressing module engaged):
>   <wsa:Action>""</wsa:Action>
> Note that I had seen valid addressing actions emitted with older AXIS2 builds; I just
noticed this problem on 14 April.
> I started discussing this problem in the following thread on the axis-user mailing list:
>   http://thread.gmane.org/gmane.comp.apache.webservices.axis.user/55272
> At least one other user has confirmed the same behavior.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message