axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rjain <rjai...@yahoo.com>
Subject Re: [axis2] How to Configure/Enable Axis2 for REST
Date Mon, 05 Mar 2007 14:40:41 GMT

Hi, 

Let me explain what are the steps I do and what is the result I get

1. I have downloaded the axis-2.1.1 distribution, and created a axis2.war
file. 
2. I have Tomcat 5.5.15, and drop the war file in the webapps folder
3. I start Tomcat, and access the following URL 
http://localhost:8080/axis2/services/listServices

It shows me the Version Service with the following URL's 

Service EPR : http://localhost:8080/axis2/services/Version
Service REST epr : http://localhost:8080/axis2/rest/Version

If I try to access the first URL
(http://localhost:8080/axis2/services/Version) I get the following message

Please enable REST support in WEB-INF/conf/axis2.xml and WEB-INF/web.xml

If I try to access the second URL (http://localhost:8080/axis2/rest/Version)
I get the following error message
<soapenv:Fault>
<faultcode/>
−
	<faultstring>
I can not find a service for this request to be serviced. Check the WSDL and
the request URI
</faultstring>
<detail/>
</soapenv:Fault>

Next, I go the axis2.xml and  in the webapps/axis/WEB-INF\conf folder and
change the following settings
    <parameter name="servicePath" locked="false">services</parameter>
    <parameter name="restPath" locked="false">rest</parameter>
    <parameter name="enableRESTInAxis2MainServlet"
locked="true">true</parameter>

The rest all parameters are default, I don't change anything else. 

I stop and start tomcat, access the List services, it shows me the same URL. 
I try to access the first URL, http://localhost:8080/axis2/services/Version,
I get the error message
<soapenv:Fault>
<faultcode/>
−
	<faultstring>
I can not find a service for this request to be serviced. Check the WSDL and
the request URI
</faultstring>
<detail/>
</soapenv:Fault>

I try to access the second URL, http://localhost:8080/axis2/rest/Version, I
get the error message
soapenv:Fault>
<faultcode/>
−
	<faultstring>
I can not find a service for this request to be serviced. Check the WSDL and
the request URI
</faultstring>
<detail/>
</soapenv:Fault>

I check the WSDL at http://localhost:8080/axis2/services/Version?wsdl, and
it is available. 

I have tried with the Nightly builds, where the configuration parameters are
simpler, I have not 
been successful. I would like to know what is the step I am missing or going
wrong. 

Thanx once again for all the help!!

regards
Rajesh


Manoj Khangaonkar wrote:
> 
> Rajesh,
> 
> REST is enabled by default.
> 
> What is not working ? What error are u getting ?
> 
> In the email below - the wrong URL is used to get the Version. The
> documentation has the right URL
> 
> Mj
> 
> 
> On 3/3/07, rjain <rjain15@yahoo.com> wrote:
>>
>>
>> Hi,
>>
>> I am trying to configure the axis2.xml and web.xml for REST. What are the
>> parameters I need to set? I have tried all combinations of parameters and
>> it
>> doesn't seem to work. Out of box axis2.war, doesn't work (the Version
>> REST
>> Service doesn't work) Is this broken and do I have to do anything. Please
>> help!!!
>>
>> Below is the conversation from the axis-user mailing list, and I haven't
>> got
>> any useful information
>>
>> regards
>> Rajesh
>>
>>
>>
>> > Hi Glen
>> >
>> > Thanx for the article. But this didn't help.
>> >
>> > If I set both the parameters as described in the document i.e.
>> > <parameter name="enableRESTInAxis2MainServlet"
>> > locked="true">true</parameter>
>> >
>> > <parameter name="disableSeparateEndpointForREST"
>> > locked="true">true</parameter>
>> >
>> > Both the Service URL are same
>> > Service EPR : http://localhost:8080/axis2/services/Version
>> > Service REST epr : http://localhost:8080/axis2/services/Version
>> >
>> > I get the following error
>> >
>> > <soapenv:Fault>
>> > <faultcode/>
>> > −
>> > <faultstring>
>> > I can not find a service for this request to be serviced. Check the
>> WSDL
>> > and
>> > the request URI
>> > </faultstring>
>> > <detail/>
>> > </soapenv:Fault>
>> >
>> >
>> > I hope this feature is not broken in the latest version. Any other
>> > pointers
>> > what I should be doing?
>> >
>>
>> Sorry, I have not done this before.  You may wish to google the
>> parameter properties "enableRESTInAxis2MainServlet" and
>> "disableSeparateEndpointForREST" separately.  Hopefully that will lead
>> you to a working configuration.
>>
>> Glen
>>
>>
>>
>>
>> > ===============================================
>> >
>> >
>> >
>> > GlenMazza wrote:
>> > >
>> > > Am Freitag, den 02.03.2007, 17:05 -0800 schrieb rjain:
>> > >> Hi
>> > >>
>> > >> I am using Axis2 1.1.1 , and I am trying to configure the "Version"
>> > >> Service
>> > >> to be RESTFul.
>> > >
>> > > ...
>> > >
>> > >> Can someone guide me to the documentation of how to Enable AXIS2 for
>> > >> REST,what are the configuration parameters I need to set to make
>> this
>> > >> successful.
>> > >>
>> > >
>> > > Search on this page[1] for the two articles (under External FAQs)
>> with
>> > > the word "REST".  Let us know if they help you.
>> > >
>> > > Glen
>> > >
>> > > [1] http://wiki.apache.org/ws/FrontPage/Axis2/
>> > >
>> > >
>> > >> Thanx!
>> > >> Rajesh
>> > >
>>
>> --
>> View this message in context:
>> http://www.nabble.com/How-to-Configure-Enable-Axis2-for-REST-tf3339998.html#a9289123
>> Sent from the Axis - Dev mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
>> For additional commands, e-mail: axis-dev-help@ws.apache.org
>>
>>
> 
> 

-- 
View this message in context: http://www.nabble.com/How-to-Configure-Enable-Axis2-for-REST-tf3339998.html#a9312570
Sent from the Axis - Dev mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message