axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Sosnoski <...@sosnoski.com>
Subject Re: [Axis2] JAXB working in 1.2RC1?
Date Thu, 29 Mar 2007 04:44:44 GMT
Dennis Sosnoski wrote:
> Is JAXB supposed to be supported in 1.2RC1? I thought this was 
> working, but don't see anything in the documentation. I tried dropping 
> the JAXB RI jars into the Axis2 lib, but even with the jars present I 
> get a CodeGenerationException: "No proper databinding has taken place" 
> when I use "-d jaxb".

That is, I get this exception when I try to run Wsdl2Java with "-d 
jaxb". If I instead use "-d jaxbri", I get an InvocationTargetException 
from the JAXBRIExtension.engage() method.

I'm not sure what the difference is between "-d jaxb" and "-d jaxbri"; 
if "-d jaxb" instead uses JaxMe I suggest this should be changed to "-d 
jaxme" - JaxMe is not and has never been a JAXB implementation, AFAIK.

  - Dennis

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message