axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe (JIRA)" <j...@apache.org>
Subject [jira] Assigned: (AXIS2-2276) Unexpected subelement handle, however, WSDL and XML input/output seems correct
Date Fri, 02 Mar 2007 06:44:51 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-2276?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Deepal Jayasinghe reassigned AXIS2-2276:
----------------------------------------

    Assignee: Amila Chinthaka Suriarachchi

> Unexpected subelement handle, however, WSDL and XML input/output seems correct
> ------------------------------------------------------------------------------
>
>                 Key: AXIS2-2276
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2276
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>    Affects Versions: 1.1.1
>         Environment: Linux, Sun jdk 1.5.
>            Reporter: Einar M R Rosenvinge
>         Assigned To: Amila Chinthaka Suriarachchi
>         Attachments: vespagateway.wsdl, vespagateway.wsdl
>
>
> See attached WSDL file.
> When running method 'createasyncfeeder', I get exception
> Exception in thread "main" java.lang.RuntimeException: java.lang.RuntimeException: Unexpected
subelement handle
>         at vespa.VespagatewayStub.fromOM(Unknown Source)
>         at vespa.VespagatewayStub.createasyncfeeder(Unknown Source)
>         at client.FeederThread.<init>(Unknown Source)
>         at client.VespaClient.main(Unknown Source)
> Caused by: java.lang.RuntimeException: Unexpected subelement handle
>         at vespa.CreateasyncfeederResponse$Factory.parse(Unknown Source)
>         ... 4 more
> SOAP request:
>     POST / HTTP/1.1
>     SOAPAction: "urn:createasyncfeeder"
>     User-Agent: Axis2
>     Host: bananarama.blah.blah.com:6100
>     Transfer-Encoding: chunked
>     Content-Type: text/xml; charset=UTF-8
>     <?xml version='1.0' encoding='UTF-8'?>
>     <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
>       <soapenv:Header />
>       <soapenv:Body>
>         <ns1:createasyncfeeder xmlns:ns1="urn:Vespa/Main" />
>       </soapenv:Body>
>     </soapenv:Envelope>
> SOAP response:
>     HTTP/1.1 200 OK
>     Server: gSOAP/2.7
>     Content-Type: text/xml; charset=utf-8
>     Content-Length: 508
>     Connection: keep-alive
>     <?xml version="1.0" encoding="UTF-8"?>
>     <SOAP-ENV:Envelope xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"

>     xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/" 
>     xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
>     xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
>     xmlns:nsv="urn:Vespa/Main">
>       <SOAP-ENV:Header>
>       </SOAP-ENV:Header>
>       <SOAP-ENV:Body>
>         <nsv:createasyncfeederResponse>
>           <handle>1172679483</handle>
>         </nsv:createasyncfeederResponse>
>       </SOAP-ENV:Body>
>     </SOAP-ENV:Envelope>
> It seems to me that elements have correct names according to schema in WSDL. 
> Please advice.
> (See also bug # AXIS2-2275).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message