axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lahiru Sandakith" <sandak...@gmail.com>
Subject Re: [jira] Commented: (AXIS2-2072) Code generator Eclipse plug-in not working when building from source
Date Thu, 08 Feb 2007 15:27:42 GMT
Hi Stuart,

On 2/8/07, Stuart Bell (JIRA) <jira@apache.org> wrote:
>
>
>     [
> https://issues.apache.org/jira/browse/AXIS2-2072?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12471332]
>
> Stuart Bell commented on AXIS2-2072:
> ------------------------------------
>
> Hi Lahiru,
>
>
> Many thanks for your patience on this issue.  I think we are narrowing
> down the problem.  I guess what I would like you to answer is:
>
> 1) Why the default plugin download is not working under JDK 1.4.x?

I  lately got to know that we relase bot axis2 with all the other component
this time through Maven with a JDK1.5 with compiler level set to 1.4 but it
cant be a problem in this case I tried this with 1.4.2_08 and verified these
did not appear a exception as you reporting. Please Log a JIRA on this also.


2) Can you tell me what the latest build I should take and where I can
> locate it?  I can download this and attempt to do a standard ANT
> build.  I'll attach my Eclipse .log file after this comment for your
> perusal.


please checkout the source by doing a  svn co
http://svn.apache.org/repos/asf/webservices/axis2/trunk/java/modules/tool<http://svn.apache.org/repos/asf/webservices/axis2/trunk/java/modules/tool/but>and
then you ll be able to build the plugins and install from ANT build.

Thanks,
>
>
> Stuart
>
> > Code generator Eclipse plug-in not working when building from source
> > --------------------------------------------------------------------
> >
> >                 Key: AXIS2-2072
> >                 URL: https://issues.apache.org/jira/browse/AXIS2-2072
> >             Project: Axis 2.0 (Axis2)
> >          Issue Type: Bug
> >          Components: codegen
> >    Affects Versions: 1.1.1
> >         Environment: Windows XP, Eclipse 3.2.1, JDK 1.4.2
> >            Reporter: Stuart Bell
> >         Assigned To: Lahiru Sandakith
> >         Attachments: .log, Axis2_Codegen_Wizard_1.2.1.zip,
> create-project.xml
> >
> >
> > Attempted to follow the installation instructions here:
> http://ws.apache.org/axis2/tools/1_1/eclipse/wsdl2java-plugin.html
> > I've never had such a difficult experience with other Eclipse
> plug-ins.  I've had to go down the route of building the plug-in from the
> source.  The create-project.xml for codegen seems to be broken as it is
> attempting to reference an axis2-1.1.1.jar which no longer exists.  It
> seems that the Axis libraries have been broken up into multiple JARs.  This
> seems to have happened changed with retrospectively updating the build
> script.
> > Also, the installation guide for the plugin is very obscure.  I am aware
> of Maven, but I have never used it.  Do I really have to spend days figuring
> out Maven just to re-build a plugin??
> > Was the plugin never developed to be just dropped into the plugins
> directory in Eclipse?
> > Regards,
> > Stuart Bell
>
> --
> This message is automatically generated by JIRA.
> -
> You can reply to this email to add a comment to the issue online.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-dev-help@ws.apache.org
>
>


-- 
Regards
Lahiru Sandakith

Mime
View raw message