axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-2066) Namespace is incorrectly modified in SOAP response message
Date Mon, 12 Feb 2007 11:42:05 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-2066?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12472266
] 

Deepal Jayasinghe commented on AXIS2-2066:
------------------------------------------

Hi Gul;
Can you please check the issue with today's SNAPSHOT if the issue is still there then pls
help me to re-create the issue.

> Namespace is incorrectly modified in SOAP response message
> ----------------------------------------------------------
>
>                 Key: AXIS2-2066
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2066
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: kernel
>    Affects Versions: 1.1
>            Reporter: Gul Onural
>         Assigned To: Deepal Jayasinghe
>
> I am seeing very strange behavior in Axis2 with the namespace in the 
> responses.
> My web service uses RawXMLINOutMessageReceiver and 
> RawXMLINOnlyMessageReceiver message receivers. My service methods 
> (actions) look like :
> public OMElement method1(OMElement inputMsg)* throws* AxisFault {
>     OMElement response;
>      // prepare response
>      return response;
> }
> What I am seeing is that the response I receive on the client side 
> contains a namespace that is different that what is set to on the server side.
> Just before return statements, my methods print response OMElement on 
> the server. In these printouts the namespaces are set to the correct ones. 
> However on the client side, I see entirely different namespace inserted in to the responses.
> For example, printout from within my methods on the web service 
> implementation, I see something like this  :
>  ?xml version="1.0" encoding="UTF-8"?>
>  <tns:XXResponse xmlns:tns="http://www.mycompany.com/XX">
>   .. Other stuff
>  </tns:XXResponse >
> However, on the client side printout, I see namespace changed to 
> something else :
>  ?xml version="1.0" encoding="UTF-8"?>
>  <tns:XXResponse xmlns:tns="http://www.mycompany.com/YY">
>   .. Other stuff
>  </tns:XXResponse >

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message