axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Amila Chinthaka Suriarachchi (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-2238) WSDL2Java doesn't generate all classes and properties of classes from complex types.
Date Fri, 23 Feb 2007 04:53:06 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-2238?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12475265
] 

Amila Chinthaka Suriarachchi commented on AXIS2-2238:
-----------------------------------------------------

I tried to answer you earlier, but some how I have missed it.

if u do not specify a data binding framwork, axis2 codegen uses the adb as the default. But
adb  does not support the following type of elements yet.

 <s:complexType name="DataSource">
                <s:sequence>
                    <s:element minOccurs="0" maxOccurs="1" name="Name" type="s:string"/>
                    <s:choice minOccurs="1" maxOccurs="1">
                        <s:element minOccurs="0" maxOccurs="1" name="DataSourceDefinition"
                                   type="tns:DataSourceDefinition"/>
                        <s:element minOccurs="0" maxOccurs="1" name="DataSourceReference"
                                   type="tns:DataSourceReference"/>
                        <s:element minOccurs="0" maxOccurs="1" name="InvalidDataSourceReference"
                                   type="tns:InvalidDataSourceReference"/>
                    </s:choice>
                </s:sequence>
            </s:complexType>

here you have a choice inside a sequence. 
if you can manage without the that choice you can remove it and put the elements directly
under sequence.
Optionally you can try out another data binding framework.
try one of these options  -d jibx -d xmlbeans -d jaxbri 

> WSDL2Java doesn't generate all classes and properties of classes from complex types.
> ------------------------------------------------------------------------------------
>
>                 Key: AXIS2-2238
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2238
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: codegen, wsdl
>    Affects Versions: 1.1.1
>         Environment: Windows XP
>            Reporter: Ravi Pal
>            Priority: Critical
>         Attachments: DataSource.java, ReportingService2005Stub.java, ReportService2005.wsdl
>
>
> I am facing an issue with Axis2 wsdl2java code generation. Some of the complex types
are not generated in Java Stub class. I am attaching the Java Class (stub) and WSDL file for
your reference.
> Please notice that "DataSourceReference", "InvalidDataSourceReference" and similar elements
are not generated in Stub class (convert extenstion to .java from .txt). 
> I used -g -ss to generate the classes too, but still DataSource class doesn't have right
properties in it. This class should have had "DataSourceReference" and "InvalidDataSourceReference"
 as a property.
> PS: I tried using nightly build as well on 1.1.1 branch.
> A quick reply/answer would be best.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message