axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stuart Bell (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-2072) Code generator Eclipse plug-in not working when building from source
Date Tue, 06 Feb 2007 16:20:05 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-2072?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12470626
] 

Stuart Bell commented on AXIS2-2072:
------------------------------------

Hi Lahiru,


Taking this back to my original problem, I downloaded the built, plugin from the following
location:


By following the instructions, I simply unbundled this zip into my eclipse/plugins directory.
 When attempting to use the codegen wizard I received an error about the CodegenWizardPlugin
class.  Looking at my eclipse .log file the following exception was reported:

Root exception:
java.lang.UnsupportedClassVersionError: org/apache/axis2/tool/codegen/eclipse/plugin/CodegenWizardPlugin
(Unsupported major.minor version 49.0)

This would suggest that the pre-built plugin that I downloaded was compiled on a version of
Java that my JDK is not compatible with.  This is what led me to building the plugin from
the source under my own compiler (JDK 1.4.2_13).

Furthermore, I would preferably like to avoid Maven just now from a time perspective and just
use the Ant approach instead to re-build the plugin.  However, I can't find the build.xml
anywhere in my source.  There only exists a create-project.xml, maven.xml and pom.xml, all
of which sound very much Maven.

So I suppose my questions would be:

1) Why does the pre-built plugin not work in the first place?  This would have saved me three
days worth of debugging and investigating this problem.

2) Where does the non-Maven ANT build script live in order for me to build the source under
my own compiler?

3) If I do manage to build the plugin, do I then have to import it into Eclipse as a PDE?
 Or can the plugin not simply be built to be installed as a plugin?  I basically don't have
the time to play around with Maven and PDE to get this to work just now.

Thanks,


Stuart

> Code generator Eclipse plug-in not working when building from source
> --------------------------------------------------------------------
>
>                 Key: AXIS2-2072
>                 URL: https://issues.apache.org/jira/browse/AXIS2-2072
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: codegen
>    Affects Versions: 1.1.1
>         Environment: Windows XP, Eclipse 3.2.1, JDK 1.4.2
>            Reporter: Stuart Bell
>         Assigned To: Lahiru Sandakith
>         Attachments: Axis2_Codegen_Wizard_1.2.1.zip, create-project.xml
>
>
> Attempted to follow the installation instructions here:  http://ws.apache.org/axis2/tools/1_1/eclipse/wsdl2java-plugin.html
> I've never had such a difficult experience with other Eclipse plug-ins.  I've had to
go down the route of building the plug-in from the source.  The create-project.xml for codegen
seems to be broken as it is attempting to reference an axis2-1.1.1.jar which no longer exists.
 It seems that the Axis libraries have been broken up into multiple JARs.  This seems to have
happened changed with retrospectively updating the build script.
> Also, the installation guide for the plugin is very obscure.  I am aware of Maven, but
I have never used it.  Do I really have to spend days figuring out Maven just to re-build
a plugin??
> Was the plugin never developed to be just dropped into the plugins directory in Eclipse?
> Regards,
> Stuart Bell

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message