axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ajith Ranabahu" <ajith.ranab...@gmail.com>
Subject Additional Axis2 documentation (Was : Axis2 web services on OracleAS OC4J)
Date Tue, 23 Jan 2007 18:37:01 GMT
Hi all,
After seeing this post I felt that we should have some documentation
that explains such known issues with servlet containers other than
tomcat, as part of the Axis2 documentation. This would be useful
rather than asking people to sift through the JIRA issues.

Ajith


---------- Forwarded message ----------
From: frogg@centrum.cz <frogg@centrum.cz>
Date: Jan 23, 2007 9:39 AM
Subject: Re: Axis2 web services on OracleAS OC4J
To: axis-user@ws.apache.org


I finally managed to allocate the source of the problem. There is an
apache http server around the oc4j and this server , when chunked
encoding is used, returns 503 - service unavailable because of CONTENT
LENGTH !! problem. So I used HTTP 1.0 and avoided this mess. But there
is still one problem when I use encrypted (using latest rampart) soap
messages. In OC4J I encouter this error:

[AJPRequestHandler-ApplicationServerThread-7] DEBUG
org.apache.rampart.handler.WSDoAllReceiver  - WSDoAllReceiver: exit
invoke()
[AJPRequestHandler-ApplicationServerThread-7] DEBUG
org.apache.axis2.transport.http.AxisServlet  -
org.apache.axis2.AxisFault: WSDoAllReceiver: security processing
failed; nested exception is:
        org.apache.ws.security.WSSecurityException: Cannot
encrypt/decrypt data; nested exception is:
        java.lang.IllegalArgumentException: No attributes are implemented
[AJPRequestHandler-ApplicationServerThread-7] DEBUG
org.apache.axis2.addressing.AddressingHelper  - isReplyRedirected:
FaultTo is null. Returning isReplyRedirected


It looks like wrong documentBuilder, because at first decrypted xml is
printed on the screen...


______________________________________________________________
> Od: frogg@centrum.cz
> Komu: "axis-user" <axis-user@ws.apache.org>
> Datum: 22.01.2007 19:25
> Předmět: Axis2 web services on OracleAS OC4J
>
>Hi, has anyone managed to configure any web service using Axis2 on Oracle
Application Server? I even tryed to deploy axis2.war on Tomcat and
OracleAS on the same machine. Whereas on Tomcat everything works just
fine, on OracleAS when I want to sumarize "validation" all libraries and
resources are available, but in the part devoted to examination of the
version it says: service is not available. The very same problem I have
when I use my own project based on web services.
>
>thanks in advance for any information, frogg
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
>For additional commands, e-mail: axis-user-help@ws.apache.org
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-user-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-user-help@ws.apache.org



-- 
Ajith Ranabahu
Mime
View raw message