axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nencho Lupanov" <nencholupa...@googlemail.com>
Subject Re: logging module sample
Date Mon, 29 Jan 2007 12:54:17 GMT
Charitha,

I recompiled the classes with jdk 1.4 and it works.

thanks,
Nencho


2007/1/29, Charitha Kankanamge <charitha@wso2.com>:
>
>
> Nencho Lupanov wrote:
> > Hi Charita,
> >
> > I did this and it works correctly,thanks.
> > What I also need is to take the source files from the
> > logging example and compile them myself.
> > what i found is that when i put the compiled files from the samples,
> > in the module archive - it works, but when i put the files compiled
> > manually by me - it fails.
> > Note that I am using the same source files.
> > Could that be just jvm version mismatch - my tomcat is running on jvm
> > 1.4 and files are compiled ising jvm 1.5?
> That could be the reason. Can you please check with the same jdk
> version. (Both using jdk1.4) and let us know?
>
> -Charitha
> >
> > Regards,
> > Nencho
> >
> >
> >
> >
> > 2007/1/26, Charitha Kankanamge <charitha@wso2.com
> > <mailto:charitha@wso2.com>>:
> >
> >     Hello Nencho,
> >     I did the following tasks in order to deploy the
> >     'MyServiceWithModule.aar'.
> >
> >     1. Added phase name="loggingPhase"  in axis2.xml as mentioned in the
> >     http://ws.apache.org/axis2/1_1_1/modules.html
> >     <http://ws.apache.org/axis2/1_1_1/modules.html>
> >     2. Executed following ant task from ..\axis2-
> 1.1.1\samples\userguide\
> >     ant generate.module
> >     3. Then logging.mar file was created at build directory. Copied that
> >     file to axis2/WEB-INF/modules
> >     4. Executed following ant task from ..\axis2-
> >     1.1.1\samples\userguide\
> >     ant generate.service
> >     5. MyServiceWithModule.aar was created at the
> >     ..samples\userguide\build
> >     directory. Copied it to axis2/WEB-INF/services
> >     6. Logged in to axis2 admin console and chaeked the service
> >
> >
> >     I can't figure out the exact issue here. Axis dev guys will be able
> to
> >     point out the reason as I just reported a bug on this.
> >
> >     https://issues.apache.org/jira/browse/AXIS2-2040
> >     <https://issues.apache.org/jira/browse/AXIS2-2040>
> >
> >
> >     Please follow the above steps (as a workaround) and check whether
> >     it is
> >     working for you.
> >
> >     regards
> >     Charitha
> >
> >
> >
> >     Nencho Lupanov wrote:
> >     > Hi Charitha,
> >     >
> >     > I already tried with logging.mar and also logging-1.1.mar.
> >     > It keep throwing the same exception, like it cannot understand the
> >     > module archive.
> >     >
> >     > I have the followin structure:
> >     >
> >     > logging.mar
> >     >    --- META-INF
> >     >            MANIFEST.MF
> >     >            module.xml
> >     >    --- userguide
> >     >             --- loggingmodule
> >     >                     LoggingModule.java
> >     >                     LogHandler.java
> >     >
> >     > this is packaged as logging.mar and put in axis2/WEB-INF/modules.
> >     > I get the java source files from the example dir.
> >     > Here it is the module.xml file:
> >     >
> >     >
> >     > <
> >     >
> >     > module name="logging" class ="
> >     userguide.loggingmodule.LoggingModule">
> >     >
> >     > <InFlow>
> >     >
> >     > <handler name="InFlowLogHandler" class
> >     > ="userguide.loggingmodule.LogHandler">
> >     >
> >     > <order phase="loggingPhase"/>
> >     >
> >     > </handler>
> >     >
> >     > </InFlow>
> >     >
> >     > <OutFlow>
> >     >
> >     > <handler name="OutFlowLogHandler" class
> >     > ="userguide.loggingmodule.LogHandler">
> >     >
> >     > <order phase="loggingPhase"/>
> >     >
> >     > </handler>
> >     >
> >     > </OutFlow>
> >     >
> >     > <OutFaultFlow>
> >     >
> >     > <handler name="FaultOutFlowLogHandler"
> >     > class="userguide.loggingmodule.LogHandler">
> >     >
> >     > <order phase="loggingPhase"/>
> >     >
> >     > </handler>
> >     >
> >     > </OutFaultFlow>
> >     >
> >     > <InFaultFlow>
> >     >
> >     > <handler name="FaultInFlowLogHandler"
> >     > class="userguide.loggingmodule.LogHandler ">
> >     >
> >     > <order phase="loggingPhase"/>
> >     >
> >     > </handler>
> >     >
> >     > </InFaultFlow>
> >     >
> >     > </module>
> >     >
> >     > Here it is the services.xml file:
> >     >
> >     >
> >     > <
> >     >
> >     > service name="MyServiceWithModule">
> >     >
> >     > <description>
> >     >
> >     > This is a sample Web Service with a logging module engaged.
> >     >
> >     > </description>
> >     >
> >     > <module ref="logging"/>
> >     >
> >     > <parameter name="ServiceClass" locked
> >     > ="false">userguide.example2.MyService</parameter>
> >     >
> >     > <operation name="echo">
> >     >
> >     > <messageReceiver
> >     > class="org.apache.axis2.receivers.RawXMLINOutMessageReceiver "/>
> >     >
> >     > </operation>
> >     >
> >     > <operation name="ping">
> >     >
> >     > <messageReceiver
> >     > class="org.apache.axis2.receivers.RawXMLINOutMessageReceiver "/>
> >     >
> >     > </operation>
> >     >
> >     > </service>
> >     >
> >     >
> >     >
> >     > about axis2.xml i put :
> >     >
> >     > <
> >     >
> >     > phase name="loggingPhase"/> for every phaseOrder type.
> >     >
> >     > I could ask:
> >     >
> >     > 1) shall i rename the module archive to logging-1.1.mar and if I
> do
> >     > that, should i reference it from the
> >     >
> >     > configuration files like: <module ref="logging"/>
> >     >
> >     > 2) Did you engage the module at service level or at system level
> >     > (<module ref="logging"/>  in axis2.xml)
> >     >
> >     > thanks in advance,
> >     > nencho
> >     >
> >     >
> >     > 2007/1/26, Charitha Kankanamge < charitha@wso2.com
> >     <mailto:charitha@wso2.com>
> >     > <mailto:charitha@wso2.com <mailto:charitha@wso2.com>>>:
> >     >
> >     >     Hi Nencho,
> >     >     I got the same error when deploying the
> >     >     sample-MyServiceWithModule.aar.
> >     >     This seems to be a bug in logging module sample.
> >     >
> >     >     As a workaround , can you please rename the
> >     'sample-logging.mar' in to
> >     >     ' logging.mar' and try again?
> >     >
> >     >     regards
> >     >     Charitha
> >     >
> >     >     Nencho Lupanov wrote:
> >     >     > Hi axis-dev team,
> >     >     >
> >     >     > I am trying to run the userguide example,especially
> >     >     > the logging module that comes with the binary distribution
> of
> >     >     axis2.1.1.
> >     >     >
> >     >     > I got the following error:
> >     >     >
> >     >     > org.apache.axis2.deployment.DeploymentException : logging
> >     module is
> >     >     > invalid or has not been deployed;
> >     >     >
> >     >     > Is this a known issue, is there any workaround?
> >     >     >
> >     >     > thanks in advance.
> >     >
> >     >
> >     >
> >     >
> >
> ---------------------------------------------------------------------
> >     >     To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
> >     <mailto:axis-dev-unsubscribe@ws.apache.org>
> >     >     <mailto:axis-dev-unsubscribe@ws.apache.org
> >     <mailto:axis-dev-unsubscribe@ws.apache.org> >
> >     >     For additional commands, e-mail: axis-dev-help@ws.apache.org
> >     <mailto:axis-dev-help@ws.apache.org>
> >     >     <mailto: axis-dev-help@ws.apache.org
> >     <mailto:axis-dev-help@ws.apache.org>>
> >     >
> >     >
> >
> >
> >
> >
> ---------------------------------------------------------------------
> >     To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
> >     <mailto:axis-dev-unsubscribe@ws.apache.org>
> >     For additional commands, e-mail: axis-dev-help@ws.apache.org
> >     <mailto:axis-dev-help@ws.apache.org>
> >
> >
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
> For additional commands, e-mail: axis-dev-help@ws.apache.org
>
>

Mime
View raw message