axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Updated: (AXIS2-1615) List service as faulty when an invalid transport is specified in the services.xml
Date Wed, 31 Jan 2007 14:50:07 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-1615?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Davanum Srinivas updated AXIS2-1615:
------------------------------------

    Assignee: Deepal Jayasinghe

> List service as faulty when an invalid transport is specified in the services.xml
> ---------------------------------------------------------------------------------
>
>                 Key: AXIS2-1615
>                 URL: https://issues.apache.org/jira/browse/AXIS2-1615
>             Project: Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: deployment
>    Affects Versions: 1.1
>         Environment: Win XP, JDK 1.5, apache tomcat 5.5.16
>            Reporter: Charitha Kankanamge
>         Assigned To: Deepal Jayasinghe
>            Priority: Minor
>         Attachments: servicetest.aar
>
>
> I defined the following services.xml and bundled it with the relevant service implementation
class in an archive.
> Archive was deployed successfuly and listed as a valid service in the admin console.
> services.xml
> =============
> <service name="Servicetest" targetNamespace="http://test.com">
>     <description> The description of the service </description>  
>     <transports> 
>        <transport>htp</transport>
>     </transports>
>      <schema schemaNamespace="http://xml.org"/> 
>      <parameter name="ServiceClass" locked="xsd:false">com.test.Servicetest</parameter>
>     
>     <operation name="mathoperation"> 
>         <messageReceiver class="org.apache.axis2.rpc.receivers.RPCMessageReceiver"/>
>     </operation>
>   </service>
> However I have noticed that the 'service' element is empty in the generated wsdl.
> This occured due to an invalid transport specified in the services.xml. Because of that,
the service should have been listed as a faulty service in admin console.
> Steps to reproduce:
> ===================
> 1. Deploy the attached service archive
> 2. Access axis2 admin console
> 3. Click on the service (servicetest)
> 4. wsdl file is displayed
> You can see an empty 'service' element in there. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message