axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Deepal Jayasinghe (JIRA)" <j...@apache.org>
Subject [jira] Commented: (AXIS2-1926) https access to service doesn't work
Date Thu, 04 Jan 2007 06:18:27 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-1926?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12462149
] 

Deepal Jayasinghe commented on AXIS2-1926:
------------------------------------------

Hi Gul,
I tested https access using Axis2-1.1.1-RC1/tomcat 5.5.16/jdk1.5. Here are my observations.

1. I did not encounter HTTP 500 error when clicking on Available Services/Version. I was able
to access the wsdl without any issues.
  Please see the attached screen shot.

It would be nice if you can check it again in your environment.

2. I got the same error in HappyAxis page about the Version service . This seems to be a bug
in Axis2-1.1.1

Thanks
Charitha


> https access to service doesn't work
> ------------------------------------
>
>                 Key: AXIS2-1926
>                 URL: https://issues.apache.org/jira/browse/AXIS2-1926
>             Project: Apache Axis 2.0 (Axis2)
>          Issue Type: Bug
>          Components: transports
>    Affects Versions: nightly
>         Environment: Tomcat 5.5.15, Axis2 nightly (Jan. 02, 2007)
>            Reporter: Gul Onural
>            Priority: Blocker
>         Attachments: localhost.2007-01-02.log
>
>
> I am trying to get the https access running for axis2 in tomcat, using Axis1.1 nightly
build of Jan. 2, 2007. 
> I have uncommented "SSL HTTP/1/1 Connector entry" in $CATALINA_HOME/conf/server.xml.

> Also created a certificate keystore using keytool. 
> https://localhost:8443/ correctly displays Tomcat homepage.  Also https://localhost:8443/axis2/

> correctly displays axis2 homepage. 
> However, when I click Available Services/Version I get 500 error, as shown below. 
> I have attached tomcat's log file. 
> Any ideas why I get this error ? 
> Gul 
> Error Message 
> HTTP Status 500 - 
> type Exception report 
> message 
> description The server encountered an internal error () that prevented it from fulfilling
this request. 
> exception 
> java.lang.NullPointerException 
>         org.apache.axis2.transport.http.ListingAgent$HTTPSListener.getEPRsForService(ListingAgent.java:406)

>         org.apache.axis2.description.AxisService.getEPRs(AxisService.java:632) 
>         org.apache.axis2.description.AxisService.printWSDL(AxisService.java:607) 
>         org.apache.axis2.transport.http.ListingAgent.processListService(ListingAgent.java:184)

>         org.apache.axis2.transport.http.AxisServlet.doGet(AxisServlet.java:182) 
>         javax.servlet.http.HttpServlet.service(HttpServlet.java:689) 
>         javax.servlet.http.HttpServlet.service(HttpServlet.java:802) 
> note The full stack trace of the root cause is available in the Apache Tomcat/5.5.15
logs. 

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: https://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message