axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sridhar (JIRA)" <axis-...@ws.apache.org>
Subject [jira] Commented: (AXIS-2536) AXIS issue in Tomcat Cluster
Date Tue, 05 Dec 2006 19:13:21 GMT
    [ http://issues.apache.org/jira/browse/AXIS-2536?page=comments#action_12455733 ] 
            
Sridhar commented on AXIS-2536:
-------------------------------

Hi cifroes

My issue was the interface which the webservice invokes was not implementing Serializable
interface. Without Serializable will work in non clustered environment but not in clustered
environment. Hope this helps.

Sri

> AXIS issue in Tomcat Cluster
> ----------------------------
>
>                 Key: AXIS-2536
>                 URL: http://issues.apache.org/jira/browse/AXIS-2536
>             Project: Apache Axis
>          Issue Type: Bug
>          Components: Serialization/Deserialization
>         Environment: Tomcat 5.0.28, AXIS, Jsdk1.4.2_06, Spring Remoting, WindowsNT
>            Reporter: Sridhar
>            Priority: Critical
>
> Hi
> We have AXIS webservice working fine in Test server which does not have a Cluster. When
I deploy this to Production server where we have two Tomcat servers as part of a Cluster,
I get the following exception:
> System.Web.Services.Protocols.SoapException: java.lang.IllegalArgumentException: Attribute
[some object] is not serializable
> at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage
message, WebResponse response, Stream responseStream, Boolean asyncCall)
>    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName,
Object[] parameters)
> I saw a similar issue in JIRA : https://issues.apache.org/jira/browse/AXIS-1920
> But this issue is closed saying that it works when 'distributable' element in web.xml
is commented.
> I can not comment this element because I need this application in Clustered environment.
Infact I already have the application in Production as Clustered and I am adding a webservice
to the same context in web.xml
> Please let me know the fix for this issue as it has become very critical for our Production
release.
> Thanks in advance
> Sri
>  

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message