axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sanjiva Weerawarana <sanj...@opensource.lk>
Subject Re: [Axis2] build break - policy?
Date Mon, 13 Nov 2006 17:13:01 GMT
Yeah but trunk has a dependency on the old Neethi code too .. Sanka was
trying to fix it by adding a dependency to the old Neethi too. Not sure
whether he was able to make it work :(. Sanka?? (Please note that the
build break has broken everyone's forward progress ...)

Sanjiva.

On Mon, 2006-11-13 at 22:23 +0530, Thilina Gunarathne wrote:
> New version is neethi 2.0..
> 
> ~Thilina
> 
> On 11/13/06, Nicholas L Gallardo <nlgallar@us.ibm.com> wrote:
>         
>         Sanka, 
>         
>         I tried changing the version of neethi to 1.1, but that didn't
>         seem to work.  Maybe there wasn't a nightly published for this
>         or something?   
>         
>         Either way, if there's a quick fix to this please let me know
>         and I can try to appy it.  We've got a few people that need to
>         build but aren't able to until this is fixed. 
>         
>         Thanks, 
>         
>         -Nick 
>         
>         
>         
>         
>         "Sanka Samaranayake"
>         <ssanka@gmail.com> 
>         
>         11/13/2006 06:14 AM 
>                Please respond to
>             axis-dev@ws.apache.org
>         
>         
>         
>         
>                      To
>         axis-dev@ws.apache.org
>                      cc
>         
>         
>                 Subject
>         Re: [Axis2]
>         build break -
>         policy?
>         
>         
>         
>         
>         
>         
>         
>         
>         
>         
>         will fix it ASAP
>         
>         Sanka
>         
>         On 11/13/06, Sanjiva Weerawarana <sanjiva@opensource.lk>
>         wrote: 
>         The new version of neethi does not ship the old code .. and
>         this is old
>         code. This has been fixed on the 1.1 branch but not merged
>         back to trunk
>         yet.
>         
>         One option is to add a dependency on the old neethi stuff
>         (too) .. and 
>         once we finish the merge remove it.
>         
>         Sanka, your call!
>         
>         Sanjiva.
>         
>         On Sun, 2006-11-12 at 22:26 -0600, Nicholas L Gallardo wrote:
>         >
>         > I'm unable to build the latest kernel module because of a
>         problem with 
>         > a prereq I'm not too familiar with.  Does anyone know where
>         the
>         > org.apache.ws.policy code comes from?  I thought this was
>         Neethi, but
>         > couldn't find that package in there.
>         >
>         > multiproject:install-callback: 
>         >     [echo] Running jar:install for Apache Axis 2.0 - Kernel
>         > java:prepare-filesystem:
>         >     [mkdir] Created dir: C:\work\apps\eclipse\workspace
>         \axis2-clean
>         > \modules\kernel\target\classes
>         > Running post goal: java:prepare-filesystem 
>         >
>         > java:compile:
>         >     [echo] Compiling to C:\work\apps\eclipse\workspace
>         \axis2-clean
>         > \modules\kernel/target/classes
>         >     [javac] Compiling 242 source files to C:\work\apps
>         \eclipse
>         > \workspace\axis2-clean\modules\kernel\target\classes 
>         >     [javac] C:\work\apps\eclipse\workspace\axis2-clean
>         \modules\kernel
>         > \src\org\apache\axis2\description
>         \WSDL20ToAxisServiceBuilder.
>         > java:34: package org.apache.ws.policy does not exist
>         >     [javac] import org.apache.ws.policy.Policy;
>         >     [javac]                             ^
>         >     [javac] C:\work\apps\eclipse\workspace\axis2-clean
>         \modules\kernel
>         > \src\org\apache\axis2\description
>         \WSDL20ToAxisServiceBuilder.
>         > java:35: package org.apache.ws.policy does not exist
>         >     [javac] import org.apache.ws.policy.PolicyReference;
>         >     [javac]                             ^
>         >     [javac] C:\work\apps\eclipse\workspace\axis2-clean
>         \modules\kernel
>         > \src\org\apache\axis2\description
>         \WSDL20ToAxisServiceBuilder.
>         > java:36: package org.apache.ws.policy.util does not exist
>         >     [javac] import
>         org.apache.ws.policy.util.DOMPolicyReader;
>         >     [javac]                                  ^
>         >     [javac] C:\work\apps\eclipse\workspace\axis2-clean
>         \modules\kernel
>         > \src\org\apache\axis2\description
>         \WSDL20ToAxisServiceBuilder.
>         > java:37: package org.apache.ws.policy.util does not exist
>         >     [javac] import org.apache.ws.policy.util.PolicyFactory;
>         >
>         > Thanks,
>         >
>         > -Nick
>         
>         
>         ---------------------------------------------------------------------
>         To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
>         For additional commands, e-mail: axis-dev-help@ws.apache.org
>         
>         
>         
>         
>         -- 
>         Sanka Samaranayake
>         WSO2 Inc.
>         T:+94-77-3506382 F:+94-11-2424304
>         
>         http://sankas.blogspot.com/
>         http://www.wso2.net/ 
>         
> 
> 
> 
> -- 
> http://webservices.apache.org/~thilina/
> http://thilinag.blogspot.com/


---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message