axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thilina Gunarathne" <cset...@gmail.com>
Subject Fwd: [Axis2] Two different builders
Date Fri, 06 Oct 2006 10:03:25 GMT
Forwarding to the Axis-dev list...

---------- Forwarded message ----------
From: Syam Prasad <syam.prasad@segsoftware.com>
Date: Oct 6, 2006 1:11 AM
Subject: RE: [Axis2] Two different builders
To: Thilina Gunarathne <csethil@gmail.com>


Thilina,

Thanks for your reply.

What I mean MTOMStAXSOAPModelBuilder builds soap message incorrectly
means....

I have soap message built in the following way.

<parent>
  <child>
    Attachment text
    <grandchild1>sometext</grandchild1>
    <grandchild2>someothertext</grandchild2>
  </child>
</parent>

Note: child element has mixed text i.e. plain text and element text.
I make attachment text from simple string and make it as MTOM attachment.

When I receive this message on the server side in the service class, this
message is being transformed in to

<parent>
  <child>Attachment text</child>
  <grandchild1>sometext</grandchild1>
  <grandchild2>someothertext</grandchild2>
</parent>

I think what you said is right. The MTOMStAXSOAPModelBuilder builder
Is looking at <xop:Include/> and replacing with OMText's and also appending
the end tag that is causing me the problem.

I am getting my attachment text correctly. But when I ask child for
grandchild1 and grandchild2 it is throwing exception because now the
grandchild1 and grandchild2 are sub elements of parent.

By the way the other builder i.e. MTOMStAXSOAPModelBuilder is giving me the
soap message as I expected.

Any suggestions/recommendation are greatly appreciated.

Regards,
Syam

-----Original Message-----
From: Thilina Gunarathne [mailto:csethil@gmail.com]
Sent: Thursday, October 05, 2006 11:57 AM
To: axis-user@ws.apache.org; syam.prasad@segsoftware.com
Subject: Re: [Axis2] Two different builders

see my comments inline..

> "org.apache.axiom.soap.impl.builder.StAXSOAPModelBuilder"
> and in another
This is to handle non-mtom-optimised messages
> "org.apache.axiom.om.impl.mtom.MTOMStAXSOAPModelBuilder"
This is to handle MTOM optimised messages... This builder identifies
the XOP:Include elements and create OMText's in the place of
XOP:Include...

Axis2 selects the appropriate builder by looking at the
message...(specifically, the content type header of the message)..

> The service with StAXSOAPModelBuilder does build my soap message correctly
> and the service with MTOMStAXSOAPModelBuilder does not build my soap
message
> correctly.
What do you mean by this...  ?? Please elaborate more..

> Is there a way to debug axis2?
http://www.wso2.net/tutorials/axis2/java/2006/07/28/debug-ws

HTH,
Thilina

>
>
>
> Thanks in advance for your help.
>
>
>
> Regards,
>
> Syam
>
>


--
http://webservices.apache.org/~thilina/
http://thilinag.blogspot.com/



-- 
http://webservices.apache.org/~thilina/
http://thilinag.blogspot.com/

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message