axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (AXIS2-1539) client samples fail
Date Sat, 28 Oct 2006 20:10:17 GMT
     [ http://issues.apache.org/jira/browse/AXIS2-1539?page=all ]

Davanum Srinivas resolved AXIS2-1539.
-------------------------------------

    Resolution: Cannot Reproduce

Works fine for me:

C:\axis2\samples\userguide>ant testEchoBlockingClient
Buildfile: build.xml
testEchoBlockingClient:
     [java] Oct 28, 2006 4:04:10 PM org.apache.axis2.deployment.DeploymentEngine prepareRepository
     [java] INFO: no services directory found , new one created
     [java] Oct 28, 2006 4:04:10 PM org.apache.axis2.deployment.DeploymentEngine prepareRepository
     [java] INFO: no modules directory found , new one created
     [java] <example1:echo xmlns:tns="http://example1.userguide" xmlns:example1="http://example1.org/example1"><example1:Text>Axis2
Echo String </example1:Text></example1:echo>
BUILD SUCCESSFUL
Total time: 10 seconds
C:\axis2\samples\userguide>ant testEchoNonBlockingClient
Buildfile: build.xml
testEchoNonBlockingClient:
     [java] Oct 28, 2006 4:04:37 PM org.apache.axis2.deployment.DeploymentEngine prepareRepository
     [java] INFO: no services directory found , new one created
     [java] Oct 28, 2006 4:04:37 PM org.apache.axis2.deployment.DeploymentEngine prepareRepository
     [java] INFO: no modules directory found , new one created
     [java] <?xml version='1.0' encoding='utf-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Header
/><soapenv:Body><example1:echo xmlns:tns="http://example1.userguide" xmlns:example1="http://example1.org/example1"><example1:Text>Axis2
Echo String </example1:Text></example1:echo></soapenv:Body></soapenv:Envelope>
BUILD SUCCESSFUL
Total time: 9 seconds

-- dims

> client samples fail
> -------------------
>
>                 Key: AXIS2-1539
>                 URL: http://issues.apache.org/jira/browse/AXIS2-1539
>             Project: Apache Axis 2.0 (Axis2)
>          Issue Type: Bug
>         Environment: Win xp sp2, Mac OS X 10.4.8, Java 5, axis2 snapshot 28/10/2006
>            Reporter: Michele Mazzucco
>            Priority: Blocker
>
> Using the snapshot the send operation of my service (asynchronous calls) fail. I've tried
with the axis2 samples and I got errors as well (the war file undeployes to /axis2)
> This is the tomcat 5.5.20 catalina.out:
> Oct 28, 2006 5:28:58 PM org.apache.catalina.core.AprLifecycleListener lifecycleEvent
> INFO: The Apache Tomcat Native library which allows optimal performance in production
environments was not found on the java.library.path: .:/Library/Java/Extensions:/System/Library/Java/Extensions:/usr/lib/java
> Oct 28, 2006 5:28:58 PM org.apache.coyote.http11.Http11BaseProtocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8080
> Oct 28, 2006 5:28:59 PM org.apache.coyote.http11.Http11BaseProtocol init
> INFO: Initializing Coyote HTTP/1.1 on http-8443
> Oct 28, 2006 5:28:59 PM org.apache.catalina.startup.Catalina load
> INFO: Initialization processed in 1357 ms
> Oct 28, 2006 5:28:59 PM org.apache.catalina.core.StandardService start
> INFO: Starting service Catalina
> Oct 28, 2006 5:28:59 PM org.apache.catalina.core.StandardEngine start
> INFO: Starting Servlet Engine: Apache Tomcat/5.5.20
> Oct 28, 2006 5:28:59 PM org.apache.catalina.core.StandardHost start
> INFO: XML validation disabled
> Oct 28, 2006 5:28:59 PM org.apache.catalina.startup.HostConfig deployWAR
> INFO: Deploying web application archive axis2.war
> Oct 28, 2006 5:29:00 PM org.apache.axis2.deployment.DeploymentEngine doDeploy
> INFO: Deploying module : addressing-1.1
> Oct 28, 2006 5:29:00 PM org.apache.axis2.deployment.DeploymentEngine doDeploy
> INFO: Deploying module : soapmonitor-1.1
> Oct 28, 2006 5:29:00 PM org.apache.axis2.deployment.DeploymentEngine doDeploy
> INFO: Deploying Web service  version.aar
> Oct 28, 2006 5:29:01 PM org.apache.coyote.http11.Http11BaseProtocol start
> INFO: Starting Coyote HTTP/1.1 on http-8080
> Oct 28, 2006 5:29:01 PM org.apache.coyote.http11.Http11BaseProtocol start
> INFO: Starting Coyote HTTP/1.1 on http-8443
> Oct 28, 2006 5:29:01 PM org.apache.jk.common.ChannelSocket init
> INFO: JK: ajp13 listening on /0.0.0.0:8009
> Oct 28, 2006 5:29:01 PM org.apache.jk.server.JkMain start
> INFO: Jk running ID=0 time=0/32  config=null
> Oct 28, 2006 5:29:01 PM org.apache.catalina.storeconfig.StoreLoader load
> INFO: Find registry server-registry.xml at classpath resource
> Oct 28, 2006 5:29:01 PM org.apache.catalina.startup.Catalina start
> INFO: Server startup in 2624 ms
> and this is the syncrhonous sample:
> Sealbook:~/Desktop/axis2-1.1-SNAPSHOT/samples/userguide nmm42$ ant testEchoBlockingClient
> Buildfile: build.xml
> testEchoBlockingClient:
>      [java] Oct 28, 2006 5:29:20 PM org.apache.axis2.deployment.DeploymentEngine prepareRepository
>      [java] INFO: no services directory found , new one created
>      [java] Oct 28, 2006 5:29:20 PM org.apache.axis2.deployment.DeploymentEngine prepareRepository
>      [java] INFO: no modules directory found , new one created
>      [java] org.apache.axis2.AxisFault: Service not found operation terminated !!
>      [java]     at org.apache.axis2.description.OutInAxisOperationClient.execute(OutInAxisOperation.java:308)
>      [java]     at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:573)
>      [java]     at org.apache.axis2.client.ServiceClient.sendReceive(ServiceClient.java:502)
>      [java]     at userguide.clients.EchoBlockingClient.main(EchoBlockingClient.java:42)
> BUILD SUCCESSFUL
> while this is the asynchronous sample
> Sealbook:~/Desktop/axis2-1.1-SNAPSHOT/samples/userguide nmm42$ ant testEchoNonBlockingClient
> Buildfile: build.xml
> testEchoNonBlockingClient:
>      [java] Oct 28, 2006 5:30:06 PM org.apache.axis2.deployment.DeploymentEngine prepareRepository
>      [java] INFO: no services directory found , new one created
>      [java] Oct 28, 2006 5:30:06 PM org.apache.axis2.deployment.DeploymentEngine prepareRepository
>      [java] INFO: no modules directory found , new one created
>      [java] java.lang.Exception: 
>      [java]     at org.apache.axis2.description.OutInAxisOperationClient$NonBlockingInvocationWorker.run(OutInAxisOperation.java:455)
>      [java]     at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:665)
>      [java]     at edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:690)
>      [java]     at java.lang.Thread.run(Thread.java:613)
> BUILD SUCCESSFUL

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

---------------------------------------------------------------------
To unsubscribe, e-mail: axis-dev-unsubscribe@ws.apache.org
For additional commands, e-mail: axis-dev-help@ws.apache.org


Mime
View raw message